Troubleshooting
Problem
An issue with missing data from JVM and Spring Boot views.


Symptom
Only the Process view is available, JVM, and Spring Boot view are not present and a warning appears in the Instana UI:
Apart from this, there will usually encounter the following message inside the agent logs:
Unknown issue code: java_home_fallback_failed
Apart from this, there will usually encounter the following message inside the agent logs:
java.nio.file.FileSystemException: /proc/3559822/root/tmp/javaagent-loader-1.3.52.jar: Read-only file system
This indicates that the agent can't attach to JVM and that the file system is Read-only.
Cause
You are missing sufficient (write in this case) permissions for the /tmp directory. Usually, it happens if you are running the Java application runs as a non-root user and the mounted filesystem is read-only (mainly because of security reasons).
Resolving The Problem
Allowing write permissions to /tmp directory and restart of the agent (as well as the JVM) should resolve the issue. As an example, in this specific case (upon which this article was created) the
/proc/PID/root points to the root file system of the container. So /proc/PID/root/tmp is the same as /tmp in container. After mounting a writable volume under /tmp the Instana agent is able to extract its temporary files to a temporary location and attach to the JVM. Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSE1JP5","label":"IBM Instana Observability"},"ARM Category":[{"code":"a8m3p000000UoUHAA0","label":"Agent-\u003EReq - Install - Config"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
08 August 2023
UID
ibm16995857