IBM Support

ODBC connection failure "Communication link failure. comm rc=8500"

Troubleshooting


Problem

Unable to make ODBC connection to IBM i using "IBM i Access ODBC Driver" despite successful connectivity testing such as cwbping <IBM i system name>.

Symptom

Using "IBM i Access ODBC Driver" may fail with error:
[IBM][System i Access ODBC Driver]Communication link failure. comm rc=8500 - System policy does not allow use of this data source.  Contact your system administrator.

Cause

IBM i Application Administration is preventing use of the ODBC driver.

Diagnosing The Problem

Check for any customization to function usage on the IBM i.
For ODBC:
WRKFCNUSG FCNID(QIBM_XE1_ODBC)
OLE DB provider:
WRKFCNUSG FCNID(QIBM_XE1_OLEDB)
.Net Data provider:
WRKFCNUSG FCNID(QIBM_XE1_DOT_NET)

Resolving The Problem

Remove any undesired function restrictions, reboot the client PC, and try the connection again.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000001gDAAAY","label":"Data Access-\u003EODBC"}],"ARM Case Number":"TS012506146","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions"}]

Document Information

Modified date:
23 March 2023

UID

ibm16965842