Troubleshooting
Problem
On Linux systems, masking a service is used to prevent the service from starting. The mask action creates a symbolic link of the service file pointing to /dev/null, which prevents the service from starting unless the service is unmasked.
Cause
Administrator accidentally masked the service.
Diagnosing The Problem
When a service is masked, the service information shows the loaded status as "masked", and when the service is started the error "Unit is masked" shows up. Administrators can confirm that the service is masked by using the following steps:
- Use SSH to log in to the QRadar Console as the root user.
- SSH to the affected host if it is not the console.
- Check the status of the service having startup issues.
systemctl status <service>
Output example:● <service>.service Loaded: masked (/dev/null; bad) Active: inactive (dead) since Mon 2023-02-13 09:07:28 CST; 3s ago Main PID: 27441 (code=exited, status=0/SUCCESS)
- Try to start the service having startup issues.
systemctl start <service>
Output example:Failed to restart <service>.service: Unit is masked.
Result
The previous output is enough for the Administrator to know whether the service is masked or not.
Resolving The Problem
To resolve the issue, Administrator must unmask the service by running the following steps:
- Use SSH to log in to the QRadar Console as the root user.
- SSH to the affected host if it is not the console.
- Unmask the service masked.
systemctl unmask <service>
- Start the service.
systemctl start <service>
The service is now unmasked and successfully started. If the service still fails to start, contact QRadar Support for assistance.
Document Location
Worldwide
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Document Information
Modified date:
07 March 2023
UID
ibm16955075