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Logs are not generated after applying Sterling OMS Fixpack with WebSphere Application Server Network Deployment

Troubleshooting


Problem

After latest fix pack is applied, logs are not getting generated for application servers when IBM Sterling Order Management Software (OMS), deployed on WebSphere Application Server Network Deployment (WAS ND). 

Symptom

NA
 

Cause

1. The only file that affects log4j2 configuration is log4j2_extra.xml.
2. Out of the box programmatic configuration(yfs.log4j2.omsConfig.disable=true) is disabled. Also, log4j2_extra.xml is not having any configuration that is leading to logs not being show up.

Diagnosing The Problem

1. Copy the contents of <runtime>/properties/log4j2.sample.xml to <runtime>/properties/log4j2_extra.xml, rebuild ear, and deploy.
2. Issue is being caused by one of the log4j2 jars being shipped with OMS is present WebSphere Application Server Network Deployment 

Resolving The Problem

If WebSphere Application Server Network Deployment is being used then, follow these steps to resolve it.

1. Run the following command from runtime (this command uninstall the bad jar)<runtime>/bin/install3rdParty.sh log4j2 2_17_1 -j ../jar/log4j2/2_17_1/log4j-web-2.17.1.jar -targetJVM EVERY -uninstall

2. Perform rebuild ear, redeploy, and restart the server.

These steps can be tried in lower environment first. Make changes only as per step 1 and validate if the logging works. No other changes are needed.

Follow the customization log4j2 configuration guide for more details:

https://www.ibm.com/docs/en/order-management-sw/10.0?topic=software-customizing-log4j2

Note: These steps apply to Sterling OMS v10 FP30 onwards deployed using WebSphere Application Server Network Deployment

Related Information

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy0AAAQ","label":"Install and Deploy"}],"ARM Case Number":"TS012035070","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
13 February 2023

UID

ibm16954395