Troubleshooting
Problem
Symptom
Cause
Diagnosing The Problem
Resolving The Problem
If WebSphere Application Server Network Deployment is being used then, follow these steps to resolve it.
1. Run the following command from runtime (this command uninstall the bad jar)<runtime>/bin/install3rdParty.sh log4j2 2_17_1 -j ../jar/log4j2/2_17_1/log4j-web-2.17.1.jar -targetJVM EVERY -uninstall
2. Perform rebuild ear, redeploy, and restart the server.
These steps can be tried in lower environment first. Make changes only as per step 1 and validate if the logging works. No other changes are needed.
Follow the customization log4j2 configuration guide for more details:
https://www.ibm.com/docs/en/order-management-sw/10.0?topic=software-customizing-log4j2
Note: These steps apply to Sterling OMS v10 FP30 onwards deployed using WebSphere Application Server Network Deployment
Related Information
Document Location
Worldwide
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Document Information
Modified date:
13 February 2023
UID
ibm16954395