IBM Support

Automatic views fail to connect to CCRC WAN server using https (TLS/SSL) from Windows client

Troubleshooting


Problem

IBM® Rational ClearCase fix pack testing has uncovered an incompatibility between newer versions of Java (8.0.7.20 and later) and IBM® GSKit version 8.0.55.26.

Symptom

Automatic view communications between a Windows client (CTE, rcleartool, or CM API) to a CCRC WAN server over TLS/SSL fails with the message:

  • ClearCase 9.1.0.4: Both rcleartool and CTE print
    • CRMAP7018: Unable to create rview_agent: For input string: "CRRDM0008E *** db_VISTA database error -905 - error opening file".
  • ClearCase 9.0.2.7: Both rcleartool and CTE print:
    • Status code: 20034; status message: Unable to complete RPC to WAN server. Error executing request 58 (Problem with the local SSL certificate). gsk_environment_init(): GSK_ERROR_CRYPTO

Cause

Java version 8.0.7.20 (and later) uses a new keystore file format that GSKit 8.0.55.26 cannot read. The 32- and 64- bit versions of IBM GSKit appear to handle the error differently, leading to significantly different error messages.

Resolving The Problem

Use this workaround to temporarily resolve the issue until it is resolved by a new version of GSKit.

On each Windows client (using CTE, rcleartool, or CM API) that communicates with a CCRC WAN server over TLS/SSL, create a config file with US-ASCII encoding with the following content on a single line, and name the file and put it in ccase-home\var\config\gskit_macro.cfg:

GSK_ICC_FIPS_MODE_PROCESSING(421)=GSK_ICC_FIPS_MODE_PROCESSING_OFF(576)

Document Location

Worldwide

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Document Information

Modified date:
25 October 2023

UID

ibm16854617