IBM Support

Cloud Pak for Security: Local admin user not found after installing on AWS

Troubleshooting


Problem

After installation of Cloud Pak for Security (CP4S), log in to common services was completed with the local admin user, resulting in the user not being found.

Symptom

Show application entitlements that are in warning, error, or not processed state:
cpctl diagnostics check_deployment --only entitle
Result:
localhost ok:
{ "ansible_loop_var": "item", "changed": false, "item": "app-cases has been processed with a status of type: Warning - reason: Warning - message: Secret soar-system-id cannot be found", "msg": "app-cases has been processed with a status of type: Warning - reason: Warning - message: Secret soar-system-id cannot be found" }

localhost ok:
{ "ansible_loop_var": "item", "changed": false, "item": "app-soar has been processed with a status of type: Warning - reason: Warning - message: Secret soar-system-id cannot be found", "msg": "app-soar has been processed with a status of type: Warning - reason: Warning - message: Secret soar-system-id cannot be found" }
Note: error message "secret soar-system-id cannot be found".

Cause

Issue is caused by skipping this prerequisite step with a serverless Red Hat OpenShift installation requiring administrator access to the Kubernetes cluster for both platform and service access policies.

Resolving The Problem

Red Hat OpenShift Serverless is installed through the Serverless Operator.

  1. Log in to the Red Hat OpenShift web console and follow the steps outlined in the Red Hat OpenShift documentation.

  2. Install the Knative Serving component. In the Red Hat OpenShift web console, click the + button located in the upper right of the screen and paste the following content in the YAML dialog box:

    apiVersion: operator.knative.dev/v1alpha1
    kind: KnativeServing
    metadata:
        name: knative-serving
        namespace: knative-serving
    spec:
        high-availability:
            replicas: 2
  3. Click the Create button to start the installation of Knative Serving component.
  4. Check the conditions in the Knative Serving overview page and ensure that all the statuses are stating True.

Document Location

Worldwide

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Document Information

Modified date:
18 November 2022

UID

ibm16840353