Troubleshooting
Problem
When your updating QRadar, receive command-line interface (CLI) uncaught error running yum command.
Symptom
During the patch test, the patch fails with the following error:
[INFO](-i-testmode) 164 packages to install
[ERROR](-i-testmode) ERROR: uncaught error running yum command for patch test, please report to QRadar support: Error: timeout
[INFO](-i-testmode) Checking Disk Space...
[INFO](-i-testmode) Disk space checks adequate
[ERROR](-i-testmode) sql pretest errored, halting.[6/9] Install & Upgrade Packages failed to complete successfully.
Errors: [6/9] Install & Upgrade Packages installing produced:
ERROR: uncaught error running yum command for patch test, please report to QRadar support: Error: timeout
Cause
The yum command is timing out while the update is trying to get information on installed packages.
Resolving The Problem
The issue is a performance issue that is causing the yum command to timeout. There are some steps that can be taken to improve the response time of yum.
- Confirm no repositories are enabled:
yum repolist
- Move any repositories listed out to another location:
mv /etc/yum.repos.d/* /root yum clean all
- Backup yum configuration:
cp /etc/yum.conf /root/yum.conf.backup
- Disable the plug-in feature in yum by running:
sed -i -e 's/plugins=1/plugins=0/' /etc/yum.conf
- Increase the yum timeout value:
grep -i timeout /etc/yum.conf
echo "timeout=120" >> /etc/yum.conf
Document Location
Worldwide
[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwszAAA","label":"Install"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
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Document Information
Modified date:
11 November 2022
UID
ibm16832632