IBM Support

All Writers Using *IBMSNMPDRV System Driver Program End With Message CPD337A on V7R5 or Higher

Question & Answer


Question

Why do all of the print writer that use the *IBMSNMPDRV system driver program immediately end with message CPD337A:  An error occurred while printing on device, on V7R5 or V7R6?

Cause

Existing LAN SNMP printer device descriptions use SNMPv1.
 
If you received a preinstalled IBM i system or performed a scratch installation of OS 7.5 or 7.6, SNMP V3 only support is enabled (ALWSNMPV3(*V3ONLY)) by default in the SNMP attributes.  This issue will occur on newly or scratch installed systems.  It is not known to happen on an upgrade to these releases.

All printers configured to use *IBMSNMPDRV system driver program fail to start because the printer device description on the IBM i and the printer hardware are not configured for SNMPv3 support.

Answer

To allow the existing SNMP printer device descriptions to work with SNMPv1, change the ALWSNMPV3 parameter in the SNMP attributes from *V3ONLY to *V3AGENT or *YES:
CHGSNMPA ALWSNMPV3(*V3AGENT)
Or
CHGSNMPA ALWSNMPV3(*YES)
 

[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000COpAAM","label":"Print-\u003EPrinter Configurations-\u003ELAN 3812 SNMP"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.5.0;7.6.0"}]

Document Information

Modified date:
08 June 2026

UID

ibm16825219