IBM Support

Unable to See Disk from VIOS Installation Menu

Question & Answer


Question

I am trying to install PowerVM Virtual I/O Server (VIOS), but when I get to the Installation Menu, I am unable to see a disk to do the install to.

Cause

This document describes the most common causes why the VIOS Installation Menu does not see a disk to install to.

Answer


1. VIOS partition does not have disk I/O controller.

  • Recommendation
    Login to the VIOS management GUI (typically an HMC) and verify the VIOS has the expected disk I/O controller allocated in the VIOS partition's profile. For assistance determining what resources are allocated to the VIOS partition, contact your HMC (or GUI management) Support Representative.

2. The disk is not properly formatted for AIX/VIOS OS.

  • Recommendation

    If the disk being used for the VIOS installation was previously used for IBM i OS, it is possible that the disk may be formatted for IBM i OS.  Ensure the disk is formatted for AIX/VIOS OS.  For details, refer to How to Format i Drives to AIX Format for the Purpose of Installing VIOS.

    SAS disks formatted as pdisk can be used as ARRAY candidates and cannot be seen during the VIOS Installation screen. Ensure disk(s) format is JBOD (512 byte blocks).
    Contact your local IBM Hardware Support Representative for assistance reformatting the disk drive.

3. VIOS Install level is not compatible with the POWER system.

  • Recommendation

    1. Verify the machine type/model supports the VIOS level you are trying to install. For details, refer to the System to VIOS maps.


4. Downleveled microcode.

  • Recommendation

    Verify system, adapter, and disk microcode are up-to-date.

    Microcode is available for download at FixCentral.
    Note: some adapter microcode levels may have minimum VIOS level requirements. Check the README file for your specific adapter type and microcode level (available on FixCentral) to see if it has VIOS level requirements.
    For microcode update questions, please, contact your local IBM Hardware Support Representative.
If none of the above apply to your environment, consider running diagnostics on the disk and the adapter or contact your local Hardware Support Representative to verify adapter and disk integrity.

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Product Synonym

virtual I/O server vios boot install installation fails failure unable see disk

Document Information

Modified date:
01 October 2024

UID

isg3T1023254