Troubleshooting
Problem
Symptom
$ entstat -all ent#|grep -i state > where ent# is the SEA
State: LIMBO
Device State: Dead
LAN State: Operational
LAN State: Operational
The following error may be found in the VIOS errlog:
IDENTIFIER: 8D424E06
Date/Time: Mon Jun 24 09:56:59 2015
...
Failure Causes
ADAPTER FAILURE
Recommended Actions
SWITCHING TO LIMBO STATE
...
ABSTRACT
Adapter link down
...
Cause
- The link status went down for the underlying physical adapter. This is the most common cause.
- The Shared Ethernet Adapter cannot ping the specified remote host--IP address to ping (netaddr)--to inform the backup Shared Ethernet Adapter that it needs to become active. If the Shared Ethernet Adapter netaddr attribute has an IP address to ping, ensure the IP is valid and pingable.
- The Shared Ethernet Adapter may be misconfigured. When using a dedicated control channel adapter and the Shared Ethernet Adapters are created using a control channel adapter with a different PVID, such misconfiguration can lead to a network storm. See "Diagnosing the problem" for more details.
- Note: If the Shared Ethernet Adapter in question is a "Simplified SEA failover" setup (no dedicated control channel adapter is being used), so this does NOT apply. To check, run: 'lsdev -dev SEA_ent# -attr netaddr'
- Problem on the network switch.
Environment
To check SEA mode, run:
$ lsdev -dev ent# -attr > ha_mode = auto or sharing
The following example shows SEA failover adapter, ent8, configured in auto mode:
$ lsdev -dev ent8 -attr
attribute value description user_settable
...
ha_mode auto High Availability Mode True
...
Diagnosing The Problem
Note: The lack of or misconfiguration of a control channel adapter would only be an "indirect" cause of Limbo state if the switch port gets shutdown due to network storm.
If answer is NO, continue to #2.
Both VIOs should return the same PVID.
2. Was the SEA in question previously working but you changed the control channel adapter to a different ent device?
If answer is NO, see Resolving the Problem for other possible causes
Resolving The Problem
Note: The SEA will not get out of LIMBO state until the Link Status is UP. If the link status is found to be DOWN, that must be corrected first.
1. Find out the physical adapter used by the SEA. Then check the VIOS error log for link errors.
In the following example, ent8 is the SEA, and ent4 is the physical adapter used by the SEA:
ent8 Available Shared Ethernet Adapter
$ lsdev -dev ent8 -attr |grep real_adapter
...
real_adapter ent4 Physical adapter associated with the SEA True
...
$ errlog|grep ent4
The VIOS errlog is a key, as sometimes, it clearly reveals the SEA switched to limbo state due to the link status of its physical adapter going down.
In the following example, ent8 is an SEA configured in failover (auto) mode using physical adapter, ent1.
If you see link errors logged by the physical adapter used by the SEA in question, consider the following:
Jun 24 09:56:59 ent4 P LNCENT_HW_ERR
Jun 24 09:56:46 ent4 T LNCENT_TX_ERR
LABEL: VIOS_SEA_ADAP_FAIL
IDENTIFIER: 8D424E06
Date/Time: Mon Jun 24 09:56:59 2015
...
Failure Causes
ADAPTER FAILURE
Recommended Actions
SWITCHING TO LIMBO STATE
...
ABSTRACT
Adapter link down
...
2. If a switch or another system is directly attached to the ethernet adapter, verify it is powered up, configured, and functioning correctly. Consult with your network administrator to find out if there was any maintenance on the switch side around the time the link error was logged by the VIOS that might help justify the link going down. Examine the switch logs specifically for the switch port connected to physical network adapter port for which the link status went down to see if the switch port is actually enabled, or perhaps shut down.
$ chdev -dev <SEA_ent#> -attr ha_mode=standby
$ chdev -dev <SEA en#> -attr state=down > where en# is the SEA interface
$ chdev -dev <SEA en#> -attr state=detach
$ rmdev -dev <SEA_ent#> -ucfg
$ rmdev -dev <SEA_real_adapter_ent#> -ucfg
$ cfgdev -dev <SEA_real_adapter_ent#>
$ cfgdev -dev <SEA_ent#>
- Try bringing the SEA network interface down, and put the SEA in Defined state as noted above. Then put an IP address on the physical adapter. Sometimes the link status may not change until you try to put an IP on the physical network adapter port.
- As a last resource, try rebooting the VIOS. Then, check if the Link Status shows UP, and if so, the SEA state show no longer be LIMBO.
The following errors are known to be logged on environments where the SEA in question was using a real adapter (ent0 in this example) with unsupported FW level, 00010000020025201905, causing the SEA (ent14) to go into limbo state:
Aug 25 12:49:47 ent0 T LNC2ENT_HW_TMP_ERR
Aug 25 12:47:59 ent0 T LNC2ENT_TX_ERR
Aug 25 12:47:47 ent0 T LNC2ENT_TX_ERR
ent0 Available 0B-00 U78CA.001.CSS00TP-P1-C4-C1-T1 PCIe3 4-Port 10GbE SR Adapter (df1020e21410e304)
Last, if none of the above apply to you and the SEA state shows LIMBO when the link status is UP, collect a snap from the VIO servers and contact your IBM SupportLine Representative for investigation.
Related Information
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Document Information
Modified date:
19 February 2022
UID
isg3T1022635