Question & Answer
Question
This document describes how to cleanup HMC installios after a failure or interruption of the command.
Cause
HMC installios process failed or was interrupted before completing, and subsequent installios command fails with a permission error, such as "/tmp/installios.lock : print Operation not permitted".
Answer
PROCEDURE
1. If a problem occurred during the installation and installios did not automatically unconfigured itself, run the following command to manually unconfigure the installios installation resources.
installios -u
Some times the command may fail with a "Permission Denied" error or an error similar to the one below. If it does, proceed with the remaining procedure.
hscroot@hostname:~> installios -u
nimol_config MESSAGE: Unconfiguring the NIMOL server...
nimol_config ERROR: The file /etc/nimol.conf does not exist.
nimol_config MESSAGE: Running undo...
ERROR unconfiguring nimol_config.
2. Check if any of the following exist. If so, they need to be removed
/tmp/installing.lock
/tmp/installios_cfg.lock
/tmp/installios_pid
To remove the file(s), you must obtain a "temporary" PESH access code to gain root access by contacting your local HMC Software Support Representative at 1-800-IBM SERV. You will need the HMC serial number.
Once you have PE shell access to the HMC, change the file(s) permissions by running
chmod 775 /tmp/<filename>
At this point, you can try 'installios -u' again or manually remove the file(s). Then try the installation again.
KNOWN ISSUES
HMC 7.3.4 has a known issue with lpar_netboot command creating log files in /tmp such that later execution will cause a log file collision resulting in a failure due to permission error. The fix is in HMC 7.3.5 with (mandatory fix) PTF MH01197. For more details, please, contact an HMC Software Support Representative.
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Document Information
Modified date:
19 February 2022
UID
isg3T1012436