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After upgrade to HMC V8.860 Service Pack 1 remote vterm no longer launches via a browser

Troubleshooting


Problem

After upgrade to HMC V8.860 Service Pack 1 remote vterm no longer launches via a browser

Symptom


When launching a vterm remotely the following error may be encountered:


    The connection has timed out

    The server at 192.168.128.1 is taking too long to respond.

    • The site could be temporarily unavailable or too busy. Try again in a few moments.
    • If you are unable to load any pages, check your computer's network connection.
    • If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Cause

The vterm launch is using the eth0 interface, resolving the hostname to the private network ipaddress instead of the correct public routable network ipaddress

Environment

HMC Version 8 Release 8.6.0 Service Pack 1 with multiple interfaces assigned ipaddresses and the public interface is not configured on eth0.

Diagnosing The Problem


When clicking "Console" -> "Open Terminal Window" remotely in a browser, the vterm does not lanch and instead the browser shows "Problem loading page" displaying the following error details:





Note the ipaddress in the URL and when this error is encountered it will not be the ipaddress that should be resolved by the public hostname accessed original in the browser..

Resolving The Problem

Install PTF MH01703 from fixcentral which includes the following fixes:



Fixed a problem where the GUI Console > Open Terminal Windows (vterm) task used a different URL then the URL of the GUI session.  Symptoms may include:
  • A vterm connection error due to resolving an incorrect HMC ip address with errors such as "The connection has timed out.   The server at x.x.x.x is taking too long to respond" where "x.x.x.x" is not the HMC's open interface used for remote access"
  • Certificate errors/warnings regarding the certificate host name such as "Your connection is not secure. The owner of <hmc ip address> has configured their website improperly. <hmc ip address> uses an invalid security certificate
    The certificate is only valid for the following names : <hmc host name>
    Error code: SEC_ERROR_UNKNOWN_ISSUER"
     

If the fix cannot be installed perform the following steps:

This error is encountered in environments where the gateway dev for the routing is set to "any".

Setting the gateway devices to the actual interface configured as the public network will resolve the error and allow the vterm to launch.

From the Classic or the Enhanced GUI:

Go to HMC Management -> Console Settings -> Change Network Settings

Click the Routing tab and check what the "Gateway device" is set to:




Change the device to the proper one for the route (eth1 in this example)

Click "OK". Retry the launch remotely and now the vterm will work.

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Document Information

Modified date:
22 September 2021

UID

nas8N1022031