IBM Support

RAID Start Device Parity Protection Failed - DEBUG MATRIX

Troubleshooting


Problem

How to diagnose why RAID (Device Parity) Fails to start.

Symptom

In DST or SST customer tries to start parity but gets the error:

Start Device Parity Protection Failed

There are no disk units eligible for the selected operation                    
due to one or more of the following reasons:


(see below for the reasons)

Cause

When starting RAID there are several layers of code involved.

DSM, slic IO, and the IOA firmware all play a role.

Diagnosing The Problem

While there are several possible causes the one that seems to trip up most customers (and the last one on the possible causes list they are shown) is the disk units are configured. That is they are in the an ASP.

So the 1st question to ask is:

Are the disks the customer wants in a RAID set configured units?

IF YES, then the only way to do this is with the system IPLED in B M

to DST. Forced DST using operator panel function 21 will NOT work.

Even when a system is IPL'd to DST Storage Management (also called Paging) can become active and block the start of RAID. The easiest way to tell if this has happened is to check the number of options that appear when Work With Disk Units is invoked.

When a system is at DST there will only be 2 options:


1. Work with disk configuration
2. Work with disk unit recovery

Whereas, when Storage Management is active, there will be 3 options listed:
1. Display disk configuration
2. Work with disk configuration
3. Work with disk unit recovery.

Resolving The Problem

If Storage Management (Paging) is active, a manual IPL to DST must be performed back to DST to start RAID.

If the Units are not configured, but RAID (Device Parity) still will not start then the possible causes as listed need to be investigated. Product Activity logs can also help. The hardware service provider may need to be engaged to assist as well.

Possible causes:
There are no disk units eligible for the selected operation due to one or more of the following reasons:                                  
                                                                               
o  All the device parity capable disk units are already device                
   parity protected.                                                          
o  Maximum number of arrays exceeded.                                          
o  An IOP is in a condition that makes the disk units attached to              
   it read/write protected.  Examine the 'Product activity log'                
   for any reference codes that are logged for the IO subsystem                
   and follow the appropriate procedure for the reference code to              
   correct the problem, if necessary.                                          
o  Not all disk units attached to an advanced function IOP have                
   reported to the system.  Retry the operation.                              
o  All the disk units in a parity set must be the same capacity                
   with a minimum number of either 3 or 4 units, and a maximum                
   number up to 18 units (depending upon the type of adapter)                  
    in the resulting parity set.                                                
o  The type/model of the disk units is not supported for the                  
   requested operation.                                                        
o  If starting device parity protection beyond the                            
   limited paging environment, all units in the                                
   array must be non-configured.  Otherwise device parity                      
   protection must be started in the limited paging                            
   environment.
                                                               

[{"Product":{"code":"SWG60","label":"IBM i"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Hardware-DASD","Platform":[{"code":"","label":"iSeries"},{"code":"PF012","label":"IBM i"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}}]

Document Information

Modified date:
18 December 2019

UID

nas8N1021983