Troubleshooting
Problem
After upgrading to PowerVC 1.3.2, remote restart of some VMs that were deployed in PowerVC 1.3.1.x fail with HTTP error 404. This is likely because the VM metadata is not getting updated in the Swift repository.
Symptom
The VM moves to 'error' state during a remote restart operation.
Cause
Some VMs deployed on PowerVC 1.3.1.x will not have the swift repository updated correctly due to an invalid token at the time of deployment. This leads to a situation where the file that swift stores on the file system has a size of 0 bytes for the VM. When a remote restart of such a VM is attempted, it fails with the message "HTTP error 404" because the rebuild of the VM on the destination host tries to access the data from Swift repository. Because the data is not there, the remote restart fails and the VM's state moves to 'error'.
Environment
PowerVC Standard and Cloud PowerVC Manager
Diagnosing The Problem
1. Remote restarting a VM deployed in PowerVC 1.3.1.x fails.
2. The VM in "error" state on PowerVC.
3. The PowerVC GUI shows the following error message,
HttpError: HTTP error 404 for method GET on path /rest/api/uom/LogicalPartition/<LPARID>/quick/PartitionID: Not Found -- REST000B The URL presented to the Management Console REST Web Services is not valid.
Resolving The Problem
To solve this problem, unmanage the VM from PowerVC and manage it again.
This will ensure that the VM's metadata is updated properly on the swift repository.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
nas8N1021764