Troubleshooting
Problem
Your IBM Apache HTTP server will not start.
Symptom
Message HTP8019 is thrown in the IBM HTTP Server job log
Cause
Authority was changed or directory removed.
Environment
IBM i
Diagnosing The Problem
View the IBM HTTP Server configuration file for your specific IBM HTTP Server. The default location for a HTTP Server named, MyServer, is the following:
/www/MyServer/conf/httpd.conf
You can use the following command to view it (replace MyServer with the name of your IBM Apache HTTP server:
EDTF '/www/MyServer/conf/httpd.conf'
Find the DocumentRoot directive and verify whether that path that follows it exists or not. The Document Root directive IFS path value is required to exist. If it does exist, then this is most likely an authority issue where the QTMHHTTP user profile does not have sufficient RX or RWX authority. Make sure the user profile, QTMHHTTP, has authority to each directory in the path.
Resolving The Problem
Make sure user profile QTMHHTTP has authority to each directory in the path.
[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CGqAAM","label":"IBM i HTTP Server"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
01 May 2025
UID
nas8N1021642