IBM Support

How To Reliably Start the IBM i NetServer At IPL

Troubleshooting


Problem

Describes the steps to make the systems reliably start the NetServer as part of an IPL

Symptom

The IBM i NetServer does not reliably start during an IPL

Cause

Various timing problems can cause this failure to happen and the default mechanisms in place do nothing to enforce the timing is correct.

Resolving The Problem

The resolution is to ensure that the NetServer is not started until after TCP/IP interfaces are initialized and the QSERVER subsystem is started. Here are the steps:

  • In Navigator for i, expand Network, Servers, then click TCP/IP Servers.
  • In the right pane, right-click 'IBM i NetServer' and select 'Properties' from the resulting pop-up menu to open the 'IBM i NetServer Properties' window.
  • In the properties window, click the 'General' tab and click 'Expand Next Start'.  Clear the option labeled 'Start when TCP/IP is started' then click the 'Save' button and close the window. This step prevents the TCP/IP startup program from automatically starting IBM i NetServer whenever it gets to it (which is probably way too early and causing the failure of the NetServer to start.)
  • Next, modify the startup program for the system.  For more information about editing the startup program, see this technote:  Changing the IPL Start-Up Program .
    In the startup program, ensure the QSERVER subsystem is being started and add the following to the end of the startup program:
    DLYJOB 300
    STRTCPSVR *NETSVR
  • Save and recompile the startup program with your changes.

The next time the system IPLs, the TCP/IP startup will not cause the NetServer to start prematurely. Instead, the command in your startup program starts the NetServer after the system has a few minutes for everything to start and initialize.

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Document Information

Modified date:
19 August 2024

UID

nas8N1020866