IBM Support

login to the Cloud Pak fails with the LDAP username which contains non-English characters

Troubleshooting


Problem

Authentication to the Cloud Pak fails for users having non-English characters in their LDAP username. They are not able to log in to any of the components.
Even though, the LDAP file allows the non-english characters. Such as: á and é, ü, or ö

Symptom

If you try to log in any Cloud Pak for Business Automation URL that uses non-English character username, the page looks blank, or if you directly log in IAM URL, you get 400:Bad request as displayed:

image

And

image 12779

Cause

There were restrictions on what are valid characters in user name and password. Limitations might be imposed by LDAP, database, or Liberty.
Hence, applications on top have to confine to it. In fact, IBM Business Automation Workflow documents non-ASCII characters are not allowed in username or password

Diagnosing The Problem

This issue was identified as a defect and resolved in CS 3.21.0 fix

Resolving The Problem

To resolve this issue, you need to upgrade your IBM Cloud Pak foundational services to version 3.21.
This fix includes both the original fix regarding the display of the full name and the names with an apostrophe, regarding user IDs that contain '(apostrophe).

 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRV9V","label":"IBM Cloud Pak foundational services"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Product Synonym

LDAP, IBM Common Services, IBM Cloud Pak for Business Automation, IBM Cloud Pak Foundational Services

Document Information

Modified date:
29 September 2022

UID

ibm16621309