Troubleshooting
Problem
The client connects to the server, but never receives a prompt to enter the logon ID or password. A client trace might show an EZA2590E message with the return code of 1121.745A7242, which is indicates that the connection has been reset. A server trace may show the interruption of a routine.
Cause
The server has a banner page that is larger than the MTU of the ftp server, or has been segmented before getting to the firewall. This causes the last byte to be something other than the carriage return/line feed (CRLF) characters x'0D0A'. Some firewalls have rulesets which require all messages to terminate with the CRLF characters, and will drop packets or reset connections whenever a non-conforming packet is received.
Resolving The Problem
Correct the problem by way of one of the following:
- Modify the firewall's ruleset
- Reduce the size of the FTP server's banner.
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21063937