IBM Support

QRadar: Upgrade fails with "System is not fully configured with QRadar" or CLI displays "ERROR: System setup failed."

Troubleshooting


Problem

How do I resolve the "System is not fully configured with QRadar. Please ensure QRadar is fully installed and configured." or the "ERROR: System setup failed. Please logout /login on the console terminal to reconfigure system." error?

Symptom

The QRadar update installer fails with the following error:
System is not fully configured with QRadar. Please ensure QRadar is fully installed and configured.
The CLI might display the following error after login and running any command, but logging out and in does not resolve it:
ERROR: System setup failed. Please logout /login on the console terminal to reconfigure system.

Cause

The installer exits if the /opt/qradar/conf/.configdone hidden file is not configured as expected by the pre-test. This error can be caused by configuration issues during installation.

Resolving The Problem

Ensure a .configdone file exists, and attempt a setup.
  1. SSH into the QRadar console as the root user. If this error occurred on another managed host, open an SSH session to that host.
  2. Create an empty .configdone file by using the following command:
    touch /opt/qradar/conf/.configdone
  3. Attempt the installation again.
    IMPORTANT: You must complete an update even if you no longer receive "System setup failed" errors because they can indicate other issues on your system such as missing docker registries. The installation helps resolving other configuration errors you might encounter. If your console is already up to date, or you would like to stay on your current version, contact support.

    Result
    If the installer fails to run or returns either of the following messages, contact support:
    Success with errors
    Failed to install

Document Location

Worldwide

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Document Information

Modified date:
26 August 2022

UID

ibm16613325