IBM Support

Cloud Pak for Security: What information to submit with a support case?

Question & Answer


Question

What system and technical information is required for opening a service request with IBM Support for Cloud Pak for Security (CP4S)?

Cause

The logs do not contain all information necessary to understanding the full scope of the issue. Gathering environmental information helps decrease time to resolution. This information is the starting point to understand how Red Hat OpenShift is deployed and Cloud Pak for Security is installed. Once system and problem information are collected, the client can securely preserve the answers for future use.

Answer

Before you open a case, gather this basic infrastructure information on hand for the Red Hat OpenShift Container Platform and Cloud Pak for Security (CP4S) environment:

Environment Information

  • What is the role or usage of the environment? For example, is the environment:
    • Production (PROD)
    • Testing (TEST)
    • Quality assurance (QA)
    • User acceptance (UAT)
    • Staging (STAGE)
    • Development (DEV)
    • Proof of concept (POC)
  • Note: Your environment might have different naming, or not listed. These release management environments are examples in no particular order.

Red Hat OpenShift Container Platform: Information

  1. What is the version of Red Hat OpenShift Container Platform?
  2. What is the default storage class, and what storage class was used for CP4S?
  3. Is there a diagram of the environment?
  4. What is the network bandwidth and latency of the network interface per node: Control Plane and Compute?
  5. Is there enough free CPU, RAM, and storage to account for:
    Periodic maintenance cycles
    Red Hat OpenShift Container Platform and CP4S upgrades
    Feature enhancements
    Defragmentation of etcd database
    Red Hat OpenShift Container Platform maintenance
    Environment growth
    NOTE: How much CPU, RAM, and storage are free for these types of scenarios?
  6. If on-premises (ON-PREM):
    • What type of hardware and how many systems?
    • If within a hypervisor (virtual machine), which product and version is being used?
    • Could a sanitized install-config.yaml be sent to determine what arguments were used for installing Red Hat OpenShift Container Platform?
    • Is this Red Hat OpenShift Container Platform a disconnected installation?
  7. If Cloud hosted:
    • Which offering: AWS, ROKS, Azure, and so on.
    • What are the specific and detailed types of images:
      For example, what did they choose in the AWS Marketplace, and how many?
  8. Is CP4S the only application installed on the cluster?
    If not CP4S is not installed on the cluster, what is installed on the Red Hat OpenShift Container Platform environment?
  9. Are there more than one IBM Cloud Pak installed?
    If other products installed, what are those products?
  10. Are there any corporate mandates on security or settings that directly impact the installation of CP4S?
  11. Do you have any custom monitoring of Red Hat OpenShift Container Platform?

Storage Class Information

  1. If on-premises (ON-PREM):
    • What is the storage device type?
    • What is the storage device size?
    • What is the storage speed: input/output operations per second (IOPS)?
    • Is the storage connected to the CP4S nodes or a VSphere hypervisor?
    • What is the storage make and model?
  2. If Cloud hosted:
    • What is the storage offering?
    • What is the storage speed: input/output operations per second (IOPS)?
    • What is the storage device size?

Network Information

  1. If on-premises (ON-PREM):
    • What is the network infrastructure?
      For example, are switches, firewalls, IDS, interconnect speed, bonding, VLANs, Jumbo Frames in use between nodes and resources? What about between IBM registry and users?
    • What product is used for the web proxy?
    • What product is used for DNS and DHCP resolution?
  2. If Cloud hosted:
    • What are the network ingress and egress speeds of the offering?
    • Are there capacity limitations (speed and amount) on egress and ingress (monthly or weekly)?
      For example, is there a CAP (limit) in place?
    • Are resources hosted between multi cloud providers? If so, what are the resources and which providers?

Cloud Pak for Security (CP4S) Information

  1. Are there any integrations that can cross over between a multi-cloud environment?
    For a multi-cloud environment, what are the integrations and where are those resources located in relation to other environments?
    What's between the cloud environments that might interfear or require extra configuration?
  2. Are you a managed service provider (MSP), and have multiple tenants?
  3. How many users are actively accessing CP4S?
  4. Is user and service authentication the same across all offerings involved with CP4S and integrations?
  5. What authentication providers and protocols are being used: SAML, LDAP, Active Directory?
  6. Is the certificate authority internal or external?
  7. Is the certificate authority publicly trusted?

Performance-Related Questions

  1. What is the problem symptom being experienced?
    For example, user interface web page use to load in less than a minute and is now taking 10 minutes to load.
  2. When did the performance issue start?
  3. What changed within the Red Hat OpenShift Container Platform and CP4S environments around the time the problem was first noticed?
  4. What parts of CP4S are not impacted by this performance problem?
  5. Does this issue affect all users?
  6. Does the issue affect all browsers?

Open a Case with Support

  1. Verify the issue is supported.
  2. Perform a backup before your team opens a case to decrease time to resolution and protect the environment.
  3. Collect logs before your team opens a case to decrease time to resolution.
  4. Open a case with support and provide the problem statement, symptoms, environment information gathered, and logs.

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m3p0000000rbnAAA","label":"Administration Task"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
23 March 2023

UID

ibm16611651