Troubleshooting
Problem
After configuring inbound email connection and creating a rule to automatically create new incidents from incoming email, you might see incidents are not created automatically but works when triggered manually.
Symptom
The user sees mail stays in the Inbox and no new incident is created in Case Management.
Looking at the cases-scripting-log-tailer container logs, which are in isc-cases-application-xxxxxx-xxxxx pod.
{"level":"warn","thread":"qtp-1591393198-45","logger":"com.resilient.scripting.rest.ExceptionMapperBase","message":"Error executing script, 'java.lang.IllegalStateException: Email message is already associated with incident \"Incident generated from email \"Lost document\" via mailbox Sneha-test-IMAP\" (0)' on line number 544","context":"default","exception":"com.resilient.scripting.exception.UnknownScriptingException: java.lang.IllegalStateException: Email message is already associated with incident \"Incident generated from email \"Lost document\" via mailbox Sneha-test-IMAP\" (0)\n\tat
Cause
This behavior is observed when multiple rules get triggered at the same time where each one tries to associate the email message with an incident. Where the first script to associate the email message works but any subsequent ones that do the same thing fail.
Environment
All CP4S versions
Resolving The Problem
Need to restart the isc-cases-application-xxxxxx-xxxxx pod.
Steps:
1. Get the pods name: oc get pods | grep isc-cases-application
2. Delete the pod: oc delete pod <podname>
Once the pod is restarted, user can see automatic cases getting created.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m0z0000001h8pAAA","label":"Cases"}],"ARM Case Number":"TS009976061","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
18 July 2022
UID
ibm16604019