Troubleshooting
Problem
When an event for the Microsoft Windows Security DSM has a user ending with dollar sign "$", this user is not extracted.
Symptom
For example, in this Windows Security event:
<13>Jun 23 12:03:29 MyServerName AgentDevice=WindowsLog AgentLogFile=Security
PluginVersion=7.3.0.41 Source=Security Computer=Server OriginatingComputer=x.x.x.1
User=SYSTEM Domain=NT AUTHORITY EventID=540 EventIDCode=540 EventType=8
EventCategory=2 RecordNumber=27741234 TimeGenerated=1656000205
TimeWritten=1656000205 Level=0 Keywords=0 Task=0 Opcode=0
Message=Successful Network Logon: User Name: SERVERFLOW2$ Domain:…
The username SERVERFLOW$ is not extracted, even if the event is open with the DSM Editor:
Note: By default the Microsoft Windows Security DSM extracts the username information from the "Message" field and not from the "User" metadate field, which usually says SYSTEM when the user is a system account.
Cause
This behavior is expected from the DSM because users ending with a dollar sign "$" are usually system accounts.
The Microsoft Windows Security DSM by design ignores the username values because they represent system accounts, and many admins prefer this behavior as they see the system accounts as noise.
For more information, see the Windows System Events or Username$ Events Display N/A in the Username field article.
Resolving The Problem
To revolve the issue, use the DSM Editor to create a custom field, then extract all the users even users for system accounts (users ending with a dollar sign "$").
This article contains two methods for extracting the user information, which might need to be customized based on the admin needs and event formats. The first method involves extracting only the SYSTEM user, while the second extracts both. Users need to complete only one of the two methods.
How to create a custom field
- Go to the DSM Editor.
- Select the Microsoft Windows Security Event Log DSM.
- Confirm you are in the Properties tab, then click the blue button with a white plus sign on it:
- Scroll down and click Create New:
- Give it the name you want, for this example the field name is Windows User, confirm the Field Type is Text, then click Save, then Select.
Result
The custom field is created and users must extract either only the SYSTEM user or both users.
How to extract only the SYSTEM user
Go the field that was created in the How to create a custom field section, then use the next configuration:

Expression Type: Regex
Expression: \tUser=SYSTEM.*User Name:\s(.*?)\s
Capture Group: 1
Make sure no spaces are left before or after the Expression.
Result
The custom field extracts the user only when this user is a SYSTEM user:

How to extract both users
Using the user that was created in the How to create a custom field section, two expressions are needed to extract both type of users:

Expression 1:
Expression Type: Regex
Expression: \tUser=SYSTEM.*User Name:\s(.*?)\s
Capture Group: 1
Expression 2:
Expression Type: Regex
Expression: User=\t.*Message=.*0x\w\w+\s\w+\\(.*?)\s
Capture Group: 1
Make sure no spaces are left before or after the Expressions.
Result
The custom fields extract the user for both type of users:

Note: Depending on the event format, the regex might need to be adjusted.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
12 July 2022
UID
ibm16602735