IBM Support

QRadar: Error when changing IMM password: Failed to set the following settings: IMM.Password.1 (IMM Error code : 80) Message : "sp_call_failed"

Troubleshooting


Problem

When changing the IMM password, instead of receiving a message that the password change completed successfully for the command response to change the IMM password for a QRadar server, the following error is returned:
Failed to set the following settings: IMM.Password.1 (IMM Error code : 80) Message : "sp_call_failed"

Cause

In QRadar versions 7.4 and later, the password requirements are set by default and require a complex password.

Diagnosing The Problem

The complex password requirements mean that the password must not be more than 15 characters long and must contain characters in at least three of the following four categories:
  • At least one lowercase alphabetical character
  • At least one uppercase alphabetical character
  • At least one numeric character
  • At least one special character

Resolving The Problem

To successfully change the password, use a password that meets the listed requirements.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000CbVWAA0","label":"ATS-Infrasec"}],"ARM Case Number":"TS008257254","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
14 December 2022

UID

ibm16591105