Troubleshooting
Problem
After installing the CTG, the TESTECI may fail with return code -26 or -3
Cause
User configuration incomplete
Resolving The Problem
When running ctgstart from the OMVS shell, the -26 return code is resolved by adding DFHJVSYSTEM_nn and DFHJVPIPE variables to the script. If the CTG is run as a started task, these need to be set by coding an export command instead. Also, it is a REQUIREMENT to code the comments too. Otherwise, the -26 code will not be cleared up.
The CICSECI.CBL sample supplied with CTG describes the different error codes which can be returned by the CICS External Call Interface. Currently, those values are:
0 | ECI-NO-ERROR |
-1 | ECI-ERR-INVALID-DATA-LENGTH |
-2 | ECI-ERR-INVALID-EXTEND-MODE |
-3 | ECI-ERR-NO-CICS |
-4 | ECI-ERR-CICS-DIED |
-5 | ECI-ERR-REQUEST-TIMEOUT |
-5 | ECI-ERR-NO-REPLY |
-6 | ECI-ERR-RESPONSE-TIMEOUT |
-7 | ECI-ERR-TRANSACTION-ABEND |
-8 | ECI-ERR-EXEC-NOT-RESIDENT |
-8 | ECI-ERR-LUW-TOKEN |
-9 | ECI-ERR-SYSTEM-ERROR |
-10 | ECI-ERR-NULL-WIN-HANDLE |
-12 | ECI-ERR-NULL-MESSAGE-ID |
-13 | ECI-ERR-THREAD-CREATE-ERROR |
-14 | ECI-ERR-INVALID-CALL-TYPE |
-15 | ECI-ERR-ALREADY-ACTIVE |
-16 | ECI-ERR-RESOURCE-SHORTAGE |
-17 | ECI-ERR-NO-SESSIONS |
-18 | ECI-ERR-NULL-SEM-HANDLE |
-19 | ECI-ERR-INVALID-DATA-AREA |
-21 | ECI-ERR-INVALID-VERSION |
-22 | ECI-ERR-UNKNOWN-SERVER |
-23 | ECI-ERR-CALL-FROM-CALLBACK |
-24 | ECI-ERR-INVALID-TRANSID |
-25 | ECI-ERR-MORE-SYSTEMS |
-26 | ECI-ERR-NO-SYSTEMS |
-27 | ECI-ERR-SECURITY-ERROR |
-28 | ECI-ERR-MAX-SYSTEMS |
-29 | ECI-ERR-MAX-SESSIONS |
-30 | ECI-ERR-ROLLEDBACK |
[{"Product":{"code":"SSGMJ2","label":"CICS Transaction Gateway"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"CTG","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"8.0;7.2;7.1;7.0;6.1;6.0;5.1;5.0","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21038732