IBM Support

QRadar: QRadar Log Source Management application fails to open due to error "New Application Required"

Troubleshooting


Problem

Administrators who try to open QRadar Log Source Management app might see the following error despite the latest version of the app is installed, "New Application Required. To modify a log source, you must use the QRadar Log Source Management app".
When this error appears, administrators cannot open the application.

Symptom

In the QRadar Log Source Management application after the administrator click to open the application, the following error is displayed:
Error01

Cause

The web browser cache prevents the application to detect the new version installed.

Environment

QRadar 7.4.0 and later.

Diagnosing The Problem

  1. Log in to the QRadar Console GUI as the administrator user.
  2. Click the Admin tab.
  3. Click the QRadar Log Source Management Application.

    log source
  4. The error "New Application Required. To modify a log source, you must use the QRadar Log Source Management app" is displayed.

    Error01
     

Resolving The Problem

  1. Ensure the latest version of the QRadar Log Source Management App is installed on the system.
  2. Log in to the QRadar Console command-line interface (CLI) as the root user.
  3. Restart the application.
    Note: This procedure can be done in two ways, CLI by using the qappmanager utility and by accessing the API user interface. This article shows the CLI procedure.
    1. Run the qappmanager utility.
       
      /opt/qradar/support/qappmanager
    2. Select option 24, "App instance - stop".
      Figure01
    3. Select an Admin token. The token must have the "Admin" value for SP and Role columns.
      Figure02
    4. Select the QRadar Log Source Management app-id, in this article is 1152.
      Figure01
    5. Once the application is in STOPPED status, select option 23, "App instance - start".
      Figure04
  4. Clear your browser cache. See How to Clear Cache and Cookies or refer to the browser documentation.
  5. Open the QRadar Log Source Management application.

    Result
    The QRadar Log Source Management application opens successfully. Alternatively, administrators can run steps 1 - 3 and clear the Tomcat cache. See QRadar: How to clear the Tomcat cache.
    If the administrator continues to experience issues after clear Tomcat's cache, contact QRadar Support for assistance.

Document Location

Worldwide

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Document Information

Modified date:
30 June 2022

UID

ibm16589199