Troubleshooting
Problem
When a Postfix and a Linux log source have the same identifier, Postfix events might get parsed by the Linux log source and vice versa in QRadar Security Information and Event Management (SIEM).
Cause
- QRadar Traffic Analysis (TA) evaluates events to determine whether they belong to an existing log source. If TA finds a matching log source identifier (LSI), and if the events, or payload, look similar, the incoming events might be correlated to an incorrect log source type.
- Another typical reason is that Postfix events might be sent to QRadar port 514 instead of a separate port as described in the DSM Configuration Guide: UDP Multiline Syslog log source parameters for PostFix MTA - IBM Documentation.
Diagnosing The Problem
To find your event payloads:
- Log in to the QRadar GUI.
- Open the log source management app: Admin > Log Sources.
- Use the Search field to search for a specific log source identifier (LSI), or for the name of a log source.
- To make the LSI column visible in the list, click the cogwheel icon to the far right.
- Enable Log Source Identifier to spot shared LSIs easier. You can move the LSI column in the list to avoid having to scroll horizontally.
- When you find your log source, select the log source and click Events to see the recent events associated with this log source in Log Activity.
- From the Display drop-down menu, select Raw Events, or double-click single events to drill down and see the event payloads.
Example Linux Payload:<35>Dec 2 17:09:35 HOSTNAME saslpasswd2: error-deleting entry from sasldb: BDB0073 DB_NOTFOUND: No matching key/data pair found
<22>Mar 10 09:36:00 HOSTNAME postfix/smtpd[30964]: 681B0600960: client=unknown, sasl_method=LOGIN, sasl_username=XXXXX
Resolving The Problem
If the Traffic Analysis does not identify the correct log source type of the event, do the following to ensure that events are associated with the correct log source type, try the following steps. If two or more log sources share the log source identifier (LSI), but are of different log source types, you might also want to check and adjust Parsing Order.
Before you begin
Note: These steps include a Deploy Changes, so plan this activity during a maintenance schedule.
- Log in to QRadar GUI.
- Click Admin tab.
- Click Log Sources.
- If Linux OS events are incorrectly associated with a Postfix log source, identify the incorrect Postfix log source and disable it.
- If the events continue to be associated with an incorrect log source type, create three log sources following this example:
-
First log source - the Gateway log source
Note: When correctly configured, no events are associated with this log source.-
Log Source Type: Universal DSM
- Protocol: UDP Multiline
-
Log Source Identifier: something unique that is not found in a Syslog Header in the events, example - postfix_gw_517.
-
Listen Port: 517
Note: You might need to adjust the target port on the Postfix host. You can also use a workaround to redirect events from a certain IP address to port 517 on QRadar: Configuring IPtables for UDP Multiline Syslog events - IBM Documentation. -
Message ID pattern: postfix\/.*?[ \[]\d+[ \]](?:- - |: )([A-Z0-9]{8,})
-
Event Formatter: No formatting
-
Show Advanced Options: Yes
-
Use As A Gateway Log Source: Yes
Image: Example log source configuration
-
-
Create a second log source. This log source is for parsing the Postfix events:
- Log Source Type: PostFix MailTransferAgent
- Protocol: Forwarded (or Syslog)
-
Log Source Identifier: Hostname, FQDN, or IP that matches the event Syslog Header information.
Image: Example log source configuration
-
Create a third log source. This log source is for parsing the Linux OS events:
-
Log Source Type: Linux OS
-
Protocol: Syslog
- Log Source Identifier: Hostname, FQDN, or IP that matches the event Syslog Header information.
Image: Example log source configuration
-
- Once the log sources are created, perform Admin tab > Deploy Changes.
- Important: Restart Event Collecting results in a service being restarted. While the service is restarted, event collection stops until service restart. Administrators with strict outage policies are advised to complete this step during a scheduled maintenance window for their organization.
Optional: If you can't see any events in Log Activity, you can also restart the event collecting services from Admin tab > Advanced > Restart Event Collecting Services to make sure all the services are running.
Result:
Events are now be associated with the correct log source.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
22 March 2023
UID
ibm16572737