IBM Support

Security Bulletin: SQL injection vulnerability in PostgreSQL affects IBM Connect:Direct Web Services (CVE-2021-23214)

Security Bulletin


Summary

IBM Connect:Direct Web Services has addressed a PostgreSQL vulnerability "A remote attacker could send specially-crafted SQL statements when the server is configured to use trust authentication with a clientcert requirement or to use cert authentication, which could allow the attacker to view, add, modify or delete information in the back-end database."

Vulnerability Details

CVEID:   CVE-2021-23214
DESCRIPTION:   PostgreSQL is vulnerable to SQL injection. A remote attacker could send specially-crafted SQL statements when the server is configured to use trust authentication with a clientcert requirement or to use cert authentication, which could allow the attacker to view, add, modify or delete information in the back-end database.
CVSS Base score: 8.1
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/213379 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

Affected Product(s)Version(s)
Sterling Connect Direct Web Services1.0
IBM Connect:Direct Web Services6.0

Remediation/Fixes

Product(s)Version(s)Remediation
Sterling Connect Direct Web Services1.0Apply 6.0.0.7, available  on Fix Central
IBM Connect:Direct Web Services6.0Apply 6.0.0.7, available  on Fix Central
IBM Connect:Direct Web Services6.1Apply 6.1.0.10, available  on Fix Central
IBM Connect:Direct Web Services6.2Apply 6.2.0.4, available  on Fix Central

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Change History

22 Feb 2022: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

Review the IBM security bulletin disclaimer and definitions regarding your responsibilities for assessing potential impact of security vulnerabilities to your environment.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS7KR7","label":"IBM Connect:Direct Web Services"},"Component":"","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"},{"code":"PF002","label":"AIX"},{"code":"PF027","label":"Solaris"}],"Version":"6.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 March 2022

UID

ibm16560414