Troubleshooting
Problem
Deleting data source configurations in Cloud Pak for Security (CP4S) still shows in the User Interface (UI) for a Data Explorer search or TII scan.
Symptom
The CP4S UI shows data sources that were previously deleted in the Connections page in both Data Explorer and Threat Intelligence Insights scans.
Cause
Deleted data source connections result in leftover configurations that result in the user interface showing them in data explorer and threat intelligence insights.
Resolving The Problem
- Log in to the CP4S environment by using the oc command where
openshift_token
andopenshift_api_url
are replaced by the login command credentials:oc login --token=<openshift_token> --server=<openshift_api_url>
- Use the
oc
command to verify that thecouchdb
service is running.Port-forward
thedefault-couchdbcluster
service:oc get svc | grep couchdb c-default-couchdbcluster-m ClusterIP None <none> 9100/TCP 3d23h default-couchdbcluster ClusterIP 127.0.0.1 <none> 443/TCP 3d23h oc port-forward svc/default-couchdbcluster 9000:443
- Record the password and username used for the
default-couchdbcluster
service the decode it:oc get secret couch-secret-default -o json (............) { "apiVersion": "v1", "data": { "password": "AAAABBBCCC==", "username": "AABBCC=" } , (............) echo AAAABBBCCC== | base64 -D echo AABBCC= | base64 -D
- Open a browser and type the following address
https://localhost:9000/_utils/
into the address bar. It requests the username and password from step 3. - Scroll down the page and click
>>
arrow to navigate to the second page or click 2 - Find the
uds-ds-connections
anduds-ds-configurations
tables. Click both to locate keys that are remaining in the tables. - Click the connections table.
- Select the account ID key we want to delete.
- Click delete.
- For UI to refresh, add new connector and only the expected
Data Source
are there now.
Document Location
Worldwide
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Document Information
Modified date:
13 May 2022
UID
ibm16556482