IBM Support

Security Bulletin: IBM i components are affected by CVE-2021-4104 (log4j version 1.x)

Security Bulletin


Summary

Multiple sub-components of IBM i ship log4j version v1.x files making them vulnerable to the issue described in the vulnerability details section. IBM Navigator for i - heritage version uses log4j v1.x and cannot be updated to log4j v2.x. Integrated Web Server (IWS) V2.6 contains unused references to log4j v1.x packages. IBM i 7.2 - Integrated Application Server (IAS) V7.1 & V8.1 and Integrated Web Server (IWS) V1.3 & V1.5 use log4j v1.x and cannot be updated to log4j v2.x. IBM i Access Client Solutions (ACS) version 1.1.8.6 and earlier included an unused log4j v1.x jar file. IBM i has addressed the applicable CVE as described in the Remediation/Fixes section.

Vulnerability Details

CVEID:   CVE-2021-4104
DESCRIPTION:   Apache Log4j could allow a remote attacker to execute arbitrary code on the system, caused by the deserialization of untrusted data when the attacker has write access to the Log4j configuration. If the deployed application is configured to use JMSAppender, an attacker could exploit this vulnerability to execute arbitrary code on the system.
CVSS Base score: 8.1
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/215048 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

Affected Product(s)Version(s)
IBM Navigator for i (heritage version only)IBM i 7.4, 7.3, and 7.2 (heritage version)
Integrated Web Server (IWS)

IBM i 7.4, 7.3, and 7.2 - V2.6

IBM i 7.2 - V1.3 and V1.5

Integrated Application Server (IAS)IBM i 7.2 - V7.1 and V8.1
IBM i Access Client Solutions1.1.8.6 and earlier

 

 

Remediation/Fixes

IBM strongly recommends addressing the vulnerability now by applying the fixes.

Integrated Web Server (IWS) V2.6 included unused references to log4j v1.x packages.  The issue can be fixed by applying PTFs to IBM i.  Releases 7.4 and 7.3 of IBM i will be fixed.

IBM i 7.2 only - Integrated Application Server (IAS) V7.1 & V8.1 and Integrated Web Services Server (IWS) V1.3 & V1.5 use log4j v1.x and cannot be updated.  Customers can fix the log4j issues by migrating to the liberty-based support already available for ten years (V2.6). These server runtimes have been removed from the 7.2 release. With this fix, the server runtimes are removed and these servers will no longer run. If still using this level of IWS, migrate the web service to the V2.6 level before applying these PTFs. Details for migrating can be found at: https://www.ibm.com/support/pages/how-migrate-your-ibm-integrated-web-services-iws-server-v13v15-v26.  The issue can be fixed by applying PTFs to IBM i.  Release 7.2 of IBM i will be fixed.

IBM Navigator for i - heritage version uses log4j v1.x and cannot be updated to log4j v2.x or be removed from use.  The issue can be fixed by discontinuing the use of the heritage version of IBM Navigator for i.  The fix will disable the ADMIN2 server (where the heritage Navigator runs) from starting and running without user interaction. Additionally, the userdata runtime cache files (where the reference to log4j can be found) are deleted by this fix.  The issue can be fixed by applying PTFs to IBM i.  Releases 7.4, 7.3, and 7.2 of IBM i will be fixed.

It is strongly recommended that heritage Navigator not be used, however if there are key features required, heritage Navigator can be enabled and started temporarily at your own risk.  To do so, refer to these instructions:   https://www.ibm.com/support/pages/heritage-navigator-enable-and-disable-instructions

Note: If heritage Navigator is started, the userdata cache files are re-created and will have to be manually removed. Details are in the above link.

Statement of direction - IBM intends to update this bulletin in the future when a new HTTP Server group PTF level removes IBM Navigator for i heritage version by deleting all associated files from the system for IBM i 7.3 & 7.4 releases.    

The IBM i PTF numbers containing the fixes follow.  Future Group PTFs for HTTP Server will also contain the fixes for this CVE.  

IBM i ReleaseHTTP Server group PTF
IBM i 7.4SF99662 level 19
IBM i 7.3SF99722 level 38
IBM i 7.2 SF99713 level 49

https://www.ibm.com/support/fixcentral

 

IBM i Access Client Solutions version 1.1.8.6 and earlier included an unused log4j v1.x jar file.  The issue can be fixed by upgrading to ACS version 1.1.8.7 or later.  Details for how to get the latest version of IBM i Access Client Solutions are available at https://www.ibm.com/support/pages/ibm-i-access-client-solutions  

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Acknowledgement

Change History

07 Jan 2022: Initial Publication
02 Mar 2022: Workarounds and mitigations were replaced with corrective PTFs in the Remediation/Fixes section. HTTP Server PTF Group levels updated.

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY. In addition to other efforts to address potential vulnerabilities, IBM periodically updates the record of components contained in our product offerings. As part of that effort, if IBM identifies previously unidentified packages in a product/service inventory, we address relevant vulnerabilities regardless of CVE date. Inclusion of an older CVEID does not demonstrate that the referenced product has been used by IBM since that date, nor that IBM was aware of a vulnerability as of that date. We are making clients aware of relevant vulnerabilities as we become aware of them. "Affected Products and Versions" referenced in IBM Security Bulletins are intended to be only products and versions that are supported by IBM and have not passed their end-of-support or warranty date. Thus, failure to reference unsupported or extended-support products and versions in this Security Bulletin does not constitute a determination by IBM that they are unaffected by the vulnerability. Reference to one or more unsupported versions in this Security Bulletin shall not create an obligation for IBM to provide fixes for any unsupported or extended-support products or versions.

Document Location

Worldwide

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SS9QQS","label":"IBM i 7.4"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.4","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSC5L9","label":"IBM i 7.2"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.2","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.4,7.3,7.2","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSTS2D","label":"IBM i 7.3"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.3","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
02 March 2022

UID

ibm16539162