IBM Support

Security Bulletin: EDB PostreSQL with IBM, EDB Postgres Advanced Server with IBM, IBM Data Management Platform (Enterprise, Standard) are vulnerable to an SQL Injection (CVE-2021-23214)

Security Bulletin


Summary

EDB PostreSQL with IBM and EDB Postgres Advanced Server with IBM are vulnerable to an SQL Injection

Vulnerability Details

CVEID:   CVE-2021-23214
DESCRIPTION:   PostgreSQL is vulnerable to SQL injection. A remote attacker could send specially-crafted SQL statements when the server is configured to use trust authentication with a clientcert requirement or to use cert authentication, which could allow the attacker to view, add, modify or delete information in the back-end database.
CVSS Base score: 8.1
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/213379 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

Affected Product(s)Version(s)

EDB PostgreSQL with IBM

EDB Postgres Advanced Server with IBM

13.1

IBM Data Management Platform for EDB Enterprise

IBM Data Management Platform for EDB Standard

2.0.0 SR1 (includes EDB v12)

IBM Data Management Platform for EDB Enterprise

1.0.0

Remediation/Fixes

Upgrade to latest version of EDB Postgres Advanced Server and PostgreSQL. 

https://www.enterprisedb.com/software-downloads-postgres

  • If you have IBM Data Management Platform for EDB Enterprise, please download EDB Postgres Advanced Server.
  • If you have IBM Data Management Platform for EDB Standard, please download PostgreSQL.

 

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Acknowledgement

Jacob Champion

Change History

24 Nov 2021: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSL5O4","label":"EDB PostgreSQL with IBM"},"Component":"","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF043","label":"Red Hat"},{"code":"PF031","label":"Ubuntu"},{"code":"PF006","label":"CentOS"}],"Version":"13.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
03 December 2021

UID

ibm16523426