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ntpq -p command returns "No association ID's returned" after VIOS update

Troubleshooting


Problem

The ntpq -p command returns "No association ID's returned" after VIOS update.
After a reboot of the VIO server, the xntpd service is active, but the command "ntpq -p" shows "No association ID's returned".
A manual restart of the xntpd daemon makes that message go away.

Symptom

The ntpq -p command returns "No association ID's returned" after VIOS update.

Cause

VIOS looks for the ntp.conf file under /home/padmin/config/ntp.conf.
While the xntpd daemon pulls its configuration from /etc/ntp.conf.

At the system boot, VIOS looks for the ntp.conf file under the path it knows - and it doesn't work as the configuration file is not properly configured.
When the xntpd daemon is restarted, it pulls the configuration from the /etc/ntp.conf file and it works.

Environment

VIOS.

Diagnosing The Problem

Looking at ps -ef output, xntpd is searching ntp.conf file under /home/padmin/config:

root 5898506 6160834 0 13:03:49 - 0:00 /usr/sbin/xntpd -c /home/padmin/config/ntp.conf

Resolving The Problem

The solution is to copy the ntp.conf file into this directory and also ntp.drift, ntp.trace, and ntp.log.

Then, edit the /home/padmin/config/ntp.conf to change following lines:
driftfile /etc/ntp.drift
tracefile /etc/ntp.trace

To:

driftfile /home/padmin/config/ntp.drift
tracefile /home/padmin/config/ntp.trace
logfile /home/padmin/config/ntp.log

Then, stop and start the xntpd:

$ stopnetsvc xntpd
$ startnetsvc xntpd

One thing to bare in mind is to keep a copy from /home/padmin/config/ntp.conf.

Document Location

Worldwide

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Document Information

Modified date:
19 October 2021

UID

ibm16506869