Question & Answer
Question
Why can't I mount my file system?
# mount /testfs
mount: 0506-334 /testfs is not a known file system.
mount: 0506-334 /testfs is not a known file system.
Cause
This error is commonly seen when there is an issue with the file system's stanza in /etc/filesystems file, for example, a missing stanza.
Answer
When you create a file system, it is expected that a mount point is created for the logical volume and the /etc/filesystems file is updated with the file system's stanza.
The following is an example of the expected output where /testfs is the mount point for logical volume /dev/fslv02 and /etc/filesystems has the stanza for /testfs:
# lsvg -l rootvg | grep fslv02
fslv02 jfs2 2 2 1 closed/syncd /testfs
fslv02 jfs2 2 2 1 closed/syncd /testfs
# lsfs /testfs
Name Nodename Mount Pt VFS Size Options Auto Accounting
/dev/fslv02 -- /testfs jfs2 1048576 rw yes no
Name Nodename Mount Pt VFS Size Options Auto Accounting
/dev/fslv02 -- /testfs jfs2 1048576 rw yes no
If the /etc/filesystems stanza for the file system is missing, you might see the following output instead:
# lsvg -l rootvg | grep fslv02
fslv02 jfs2 2 2 1 closed/syncd N/A
fslv02 jfs2 2 2 1 closed/syncd N/A
# lsfs /testfs
lsfs: 0506-915 No record matching /testfs was found in /etc/filesystems.
lsfs: 0506-915 No record matching /testfs was found in /etc/filesystems.
To repopulate /etc/filesystems with the file system's stanza, use the imfs command. The imfs method is preferred instead of a manual edit since imfs uses information stored in the logical volume control block to repopulate /etc/filesystems.
Caution: Do not run crfs command in an attempt to create the mount point since it formats the logical volume and causes data loss. If you run crfs, the only way to recover is to restore the file system data from a good backup.
In our example, first check that the label for the fslv02 logical volume is indeed /testfs.
In our example, first check that the label for the fslv02 logical volume is indeed /testfs.
# getlvcb -AT fslv02
AIX LVCB
intrapolicy = m
copies = 1
interpolicy = m
lvid = 00f63f5d00004c000000016983aa827f.6
lvname = fslv02
label = /testfs
machine id = 63F5D4C00
number lps = 2
relocatable = y
strict = y
stripe width = 0
stripe size in exponent = 0
type = jfs2
upperbound = 32
fs = vfs=jfs2:log=/dev/hd8:mount=true:options=rw:account=false
time created = Wed Oct 6 10:58:38 2021
time modified = Wed Oct 6 10:58:42 2021
AIX LVCB
intrapolicy = m
copies = 1
interpolicy = m
lvid = 00f63f5d00004c000000016983aa827f.6
lvname = fslv02
label = /testfs
machine id = 63F5D4C00
number lps = 2
relocatable = y
strict = y
stripe width = 0
stripe size in exponent = 0
type = jfs2
upperbound = 32
fs = vfs=jfs2:log=/dev/hd8:mount=true:options=rw:account=false
time created = Wed Oct 6 10:58:38 2021
time modified = Wed Oct 6 10:58:42 2021
Next, run the imfs command to repopulate the stanza for fslv02.
# imfs -l /dev/fslv02
Now, check that the stanza is added. Any errors in running the imfs warrants a closer look at /etc/filesystems.
# lsfs /testfs
Name Nodename Mount Pt VFS Size Options Auto Accounting
/dev/fslv02 -- /testfs jfs2 1048576 rw yes no
Name Nodename Mount Pt VFS Size Options Auto Accounting
/dev/fslv02 -- /testfs jfs2 1048576 rw yes no
We can now mount /testfs:
# mount /testfs
# df /testfs
Filesystem 512-blocks Free %Used Iused %Iused Mounted on
/dev/fslv02 1048576 1047760 1% 4 1% /testfs
SUPPORT:
If more assistance is required, follow these instructions to open a support case for software under warranty or with an active and valid support contract.
a. Document or take screen captures of all symptoms, errors, and messages that occurred.
b. Capture any logs or data relevant to the situation.
c. Contact IBM to open a case:
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-If you require telephone support, visit the web page:
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d. Provide a good description of your issue and reference this technote
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Related Information
[{"Type":"MASTER","Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG10","label":"AIX"},"ARM Category":[{"code":"a8m0z000000cvyeAAA","label":"Filesystem"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"}],"Version":"All Versions"}]
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Document Information
Modified date:
12 October 2021
UID
ibm16497045