Troubleshooting
Problem
The message is seen on the console:
AGMA0073E - AGMAXAPI error detected during tracking in %s
Where "%s" is the CICS job name where the error occurred.
Cause
This message is printed to the console when IBM® Z Application Performance Monitor Connect (zAPM Connect) detects a possible loop inside a CICS® Region. The code prevents the loop, exits, and CICS® continues to operate normally. zAPM Connect prints the AGMA0073E message to the console to alert you.
Diagnosing The Problem
If AGMA0073E appears in the console, do the following:
1) Dump the zAPM Connect container address space, including the Common Area Data Space (CADS) use the following commands:
DUMP COMM=('dumpname')
R rr,JOBNAME=agmaproc,DSPNAME=('agmaproc'.CYTAnnnn),CONT
R rr,SDATA=(LPA,LSQA,PSA,RGN,SQA,SUM,TRT,SWA,CSA)
where:
"dumpname" is any label
"agmaproc" is the jobname of the container address space (default is AGMAPROC)
"nnnn" is the 4 character subsystem id of the container (the SSNM=nnnn startup parameter
also seen in the AGMA0073E message).
2) Dump the CICS® address space that was identified in the AGMA0073E message, use the following commands.
DUMP COMM=('dumpname')
R rr,JOBNAME=cicrgn,CONT
R rr,SDATA=(LPA,LSQA,PSA,RGN,SQA,SUM,TRT,SWA,CSA)
where:
"dumpname" is any label
"cicsrgn" is the CICS address space that was identified in the AGMA0073E message
3) If they are available, collect the unformatted CICS® AUX trace data sets of the CICS® address space that was hung.
4) If the condition can be re-created and the CICS® AUX trace was not running, start the AUX tracing before performing the re-create. If the zAPM Container trace is not started, start the zAPM Connect container trace by issuing the following command:
/F agmaproc,AGMA DEBUG EVENTS
where "agmaproc" is the jobname of the container address space. The default is AGMAPROC.
Send in the dump of zAPM container (with CADS), CICS® dump, AUX trace, zAPM job log, and CICS® job log to IBM support.
Resolving The Problem
APAR OA61251 detects the loop and drops you out of the loop. It unfortunately does not address the underlying condition as to why the loop occurred. Automation can be used to key off the AGMA0073E message. If it occurs, follow the instructions in the section "Diagnosing the Problem" and send the documentation in to IBM by opening a case.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB35","label":"Mainframe SW"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSYHZ9","label":"IBM Z Application Performance Management Connect"},"ARM Category":[{"code":"a8m0z0000001gIPAAY","label":"zAPM Connect-\u003ECICS"}],"ARM Case Number":"TS004858573","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"6.1.0"}]
Was this topic helpful?
Document Information
Modified date:
20 February 2022
UID
ibm16481693