Troubleshooting
Problem
In some instances, you notice that although the QRadar Deployment Intelligence (QDI) app is running well, some widgets fail to populate and display a message:
Failure in Health Metrics or data collection
Symptom
On the QRadar Deployment Intelligence (QDI) user interface, you observe one or more widgets displaying the message:
Failure in Health Metrics or data collection
Cause
One of the reasons for the error message is that the events from Health Metrics log source are not being seen in the Log Activity tab.
Diagnosing The Problem
From the Log Activity tab, verify whether you are seeing events from the Health Metrics log source.
- Run a search with a filter by using the Add Filter tab.
- Set the filter to: Log Source is Health Metrics::<hostname>
Resolving The Problem
In some cases, Health Metrics events are not seen because a routing rule has been written to drop them. Follow these steps to disable any such routing rule:
- Click Admin tab > Routing Rules and check whether any routing rule exists that can drop events from the Health Metrics log source.
- If such a rule exists, disable that rule.
- From the Log Activity tab, verify you are seeing events from the Health Metrics log source.
- Run a search with a filter using the Add Filter tab.
- Set the filter to: Log Source is Health Metrics::<hostname>
Results
After the Health Metrics events appear on the Log Activity tab, check whether the QDI widgets are populated with appropriate graphs and data.
Document Location
Worldwide
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Document Information
Modified date:
14 July 2021
UID
ibm16471181