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QRadar: LDAPS configuration test results in "The server requires binds to turn on integrity checking if SSL\TLS are not already active on the connection"

Troubleshooting


Problem

LDAPS authentication is configured in the environment, but testing the connection fails with the error "Unable to connect to LDAP server. Please check your settings and try again".

Symptom

In the /var/log/qradar.log file, the following message is prompted:
 
[tomcat.tomcat] [<Console Hostname>@<Console IP> (259962926) /console/JSON
-RPC/QRadar.isLDAPConnectionAvailable QRadar.isLDAPConnectionAvailable]com.q1labs.core.shared.ldap.SimpleLdapClient: 
[ERROR] [NOT:0000003000][<Console IP>/- -] [-/- -]Exception occurred when checking if ldap connection is available

[tomcat.tomcat] [<Console Hostname>@<Console IP> (259962926) /console/JSON
-RPC/QRadar.isLDAPConnectionAvailable QRadar.isLDAPConnectionAvailable] javax.naming.AuthenticationNotSupportedException: 
[LDAP: error code 8 - 00002028: LdapErr: DSID-0C090276, comment:
The server requires binds to turn on integrity checking if SSL\TLS are not already active on the connection, data 0,
 v2580^@]; remaining name 'dc=example,dc=client,dc=com'

Cause

As the LDAP server is configured to require signed communication, simple bind requests (through port 389 for example) are rejected by the LDAP server.

Resolving The Problem

Configure your user directory to connect through SSL (LDAPS).  

  1. On the Admin tab, click Authentication.
  2. Click Authentication Module Settings.
  3. From the Authentication Module list, select LDAP.
  4. The Server URL parameter must match ldaps://<LDAP Server>:<port>
    Note: The default port for LDAPS is 636 and for multi-domain configurations, the Global Catalog port 3269 can be used.
  5. Ensure SSL Connection is set to True and TLS is set to False.

    Figure2

Results

Test connection now succeeds.

Document Location

Worldwide

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Document Information

Modified date:
22 July 2021

UID

ibm16463591