Troubleshooting
Problem
The VM backup fails with the following errors reported in the datamover error log (dsmerror.log).
ANS9365E VMware vStorage API error for virtual machine 'VM_NAME'.
IBM Spectrum Protect function name: CreateSnapshot_USCORETask
IBM Spectrum Protect file: ..\..\common\vm\vmvisdk.cpp (6857)
API return code: 2094 API error message: An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.
Cause
The IBM Spectrum Protect for Virtual Environment Data Protection for VMware relies on a quiesced snapshot for the backups and usually the Quiescing error is seen from the vSphere web client according to the instructions in the following link:
This technote applies only if the Manual Snapshot with the Quiescing option completed successfully.
Environment
IBM Spectrum Protect for Virtual Environments Data Protection for VMware on all supported Platforms
Diagnosing The Problem
1- Take a Snapshot for the affected VM with the quiescing option selected :
2- Right click on the guest VM > Snapshots > Manage Snapshots and the "Quiesce guest file system" shows "NO" as showing in the following screen capture:
Although, the manual snapshot with the quiescing shows as successful. The Quiescing is set to NO according to the previous screen capture and it points to a possible issue with the VMware Snapshot Provider on the VM Guest
3- Check the Windows Services and confirm that the VMware Snapshot Provider service is Disabled.
Resolving The Problem
Enable the VMware Snapshot Provider service on the affected VM guest and engage VMware Support to further investigate the quiescing errors.
Document Location
Worldwide
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Document Information
Modified date:
07 June 2021
UID
ibm16458249