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Error message MCH3402 sent from program AiUpcallProgram

Troubleshooting


Problem

Various operating system operations result in error message MCH3402 sent from program AiUpcallProgram. Multiple seemingly unrelated code paths can be affected by this message. This could potentially affect nearly any operating system function.

Symptom

MCH3402 f/AiUpcallProgram

Cause

This error is most likely caused by a damaged system entry point table (QSYS/QINSEPT).

Diagnosing The Problem

If an error message of MCH3402 from program AiUpcallProgram is received, it most likely indicates a problem with the system entry point table. To determine if this is the case, run the following command to dump the system entry point table:


    DMPSYSOBJ OBJ(QINSEPT) CONTEXT(QSYS)

This will produce a spool containing the contents of the system entry point table. View the spool file, and search for the word "DESTROYED". If found, this indicates that the pointer stored in the entry point table for that particular program no longer points to a valid location. It could mean the program has been deleted, or replaced with a different version. Following is an example of what this would look like in the spool file:
       
    007C30   SYP 02 01 QCMDCHK            
    007C40   OBJECT ADDRESSED DESTROYED-  
    007C50   SYP 02 01 QCANPARS            

If found, then, the system entry point table (QSYS/QINSEPT) needs to be corrected.

Resolving The Problem

If it has been determined that the system entry point table has an invalid entry, steps must be taken to correct it. First, the missing object needs to be identified. The system entry point table can be dumped from another IBM i server running at the same operating system level. As the addresses will be at the same offset for the same operating system release, identifying the object at the same address will identify the missing object. In the example above, a system without the problem would show (search on 007C40):



    007C30   SYP 02 01 QCMDCHK  
    007C40   SYP 02 01 QCMDEXC  
    007C50   SYP 02 01 QCANPARS
This would indicate that the object that cannot be located is QCMDEXC.

After the program has been identified, there are a couple of possible solutions:

1.) Apply the most recent PTF for the affected program.
    The PTF application process will cause the address stored in the system entry point table to be updated.
2.) Contact technical support.
    An IBM i technical support representative may be able to manually correct the system entry point table. However, this will require that the program still exists on the server. If the program is missing, then it must be recovered through either a PTF or a restore operation.

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Document Information

Modified date:
18 December 2019

UID

nas8N1019748