Troubleshooting
Problem
Users report that logins are slow when using LDAP or LDAP with Active Directory authentication. Slow authentication or timeout issues to the user interface can indicate a configuration issue. This technical note guides administrators through common issues with slow authentication or timeout issues in the QRadar LDAP configuration.
Symptom
Users may experience longer wait times than expected at the login page:


Cause
Common causes for slow logins:
- The base statement in the LDAP configuration is too wide.
- The LDAP server is a Microsoft Active Directory using referrals.
Diagnosing The Problem
Scenario 1: Base statement too wide
To diagnose slow logins to LDAP, you can confirm the Distinguished Name (User Base DN) from your the LDAP Server. If you do not have permissions to complete queries on your LDAP system, contact your LDAP/AD administrator to provide the information.
To diagnose slow logins to LDAP, you can confirm the Distinguished Name (User Base DN) from your the LDAP Server. If you do not have permissions to complete queries on your LDAP system, contact your LDAP/AD administrator to provide the information.
- From the LDAP Server, open the Powershell utility.
- To verify the user permissions, replace <username> with the actual username in the following command:
Get-ADUser -Identity <username> -Properties *
- The DistinguishedName returned by the query indicates the path to the user. For example, analyst1 has a path of CN=Users,DC=test,DC=internal.
DistinguishedName : CN=analyst1,CN=Users,DC=test,DC=internal
- Verify the Distinguished Name is correct for your LDAP server in the User Base DN field.
Results
The previous output states that the path to the analyst1 user is CN=Users,DC=test,DC=internal. However, the base statement uses DC=test,DC=internal. Therefore the query must sort through all the entries and not specifically in Users.
Scenario 2: Referrals
LDAP authentications that use Active Directory implementations do not contain the entire record information for the user requested. When this occurs, the system sends a response to use a referral. If the Referral field to configured to use the follow option in the user interface, the request can introduce delay until the record is provided.
LDAP authentications that use Active Directory implementations do not contain the entire record information for the user requested. When this occurs, the system sends a response to use a referral. If the Referral field to configured to use the follow option in the user interface, the request can introduce delay until the record is provided.
Resolving The Problem
Scenario 1
- The administrator can confirm and update the User Base DN statement based on the Distinguished Name from the LDAP server. Tuning your configuration allows login requests to complete in a timely manner.
- Click Save.
- On the Admin tab, click Deploy Changes.
Scenario 2
- Review the Server URL field to determine if ports TCP/389 or TCP/636 are used when the Referral field is set to follow.
Note: Administrators with LDAP ports configured to use TCP/389 or TCP/636 might be experiencing a reported issue where an LDAP port is required. For more information, see: APAR IJ27713: UNABLE TO LOGIN USING ENCRYPTED LDAP WITH MICROSOFT AD SERVICES ON STANDARD LDAP PORTS. - To resolve slow login issues, update the Server URL field to use a Global Catalog ports (TCP/3268 or TCP/3269). For example:
ldap://xxx.xxx.xxx.xxx:3268
ldaps://xxx.xxx.xxx.xxx:3269 - Click Save.
- On the Admin tab, click Deploy Changes.
Result
The user can now login in a timely manner. If you continue to experience issues with slow LDAP authentication or errors when logging in, contact QRadar Support.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
18 May 2021
UID
ibm16443619