IBM Support

Cannot see push notifications for IBM Cognos Analytics Reports iOS app

Troubleshooting


Problem

If you are an IBM Cognos Analytics Reports iOS app user on Cognos Analytics version 11.0.13 FP3 or older, you will not receive push notifications for the Cognos Analytics Reports app.

Symptom

Cognos Analytics Reports users no longer receive push notifications on their iOS devices.

Cause

The Cognos Analytics Reports app uses the Apple Push Notification service (APNs) to deliver notifications to users, such as when there are new reports or report versions delivered to them. The binary protocol push notification service that was being used by Cognos Analytics Reports has been de-activated by Apple.

Resolving The Problem

To continue receiving push notifications for the Cognos Analytics Reports app, the following requirements must be met:
  • Users must upgrade to the latest iOS version of the IBM Cognos Analytics Reports app, and
  • Upgrade to IBM Cognos Analytics 11.0.13 FP4, or
  • Upgrade to IBM Cognos Analytics 11.1.7 FP2 IF 1034, or
  • Upgrade to IBM Cognos Analytics 11.2.0.
Once the Cognos Analytics system is upgraded to the new software there will be no need to maintain a yearly certificate upgrade, this will then be handled automatically.

Document Location

Worldwide

[{"Type":"SW","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl43AAC","label":"Cognos Mobile"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
19 May 2021

UID

ibm16442985