IBM Support

Users are not able to log in to LMT by using LDAP authentication after upgrading to 9.2.23

Troubleshooting


Problem

After upgrading License Metric Tool to application update 9.2.23, users might observe problems with secure LDAP authentication.

Symptom

When you log in to License Metric Tool by using a pre-configured LDAP user, the following message might appear:
'The Directory Server is misconfigured. Make sure the LDAP attributes have been properly mapped.'
Additionally, a similar error message might also appear in the tema.log file:
SRVE0292I: Servlet Message - [tema]:.[WARN] The Directory Server is misconfigured. Make sure the LDAP attributes have been properly mapped.

Cause

This issue is being fixed under APAR IJ31909. The APAR will be officially fixed in application update 9.2.24.

Resolving The Problem

To work around the issue, perform the following steps:
1. Stop the License Metric Tool server.
2. Open the ../server1/jvm.options file and add the following setting as the last entry:
-Dcom.ibm.jsse2.overrideDefaultCSName=true
3. Start the License Metric Tool server.
4. Verify whether you can log in by using the LDAP user.
5. If the problem persist, open the ../server1/jvm.options file and add the following settings:
-Dcom.unboundid.util.SSLUtil.defaultSSLProtocol=TLSV1.2
-Dcom.unboundid.util.SSLUtil.enabledSSLProtocols=TLSV1.2
6. Restart the License Metric Tool server.

Document Location

Worldwide

[{"Type":"SW","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS8JFY","label":"IBM License Metric Tool"},"ARM Category":[{"code":"a8m0z000000CbkMAAS","label":"Upgrade->Upgrade LMT server"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.2.0"}]

Document Information

Modified date:
07 April 2021

UID

ibm16440615