IBM Support

iBase database can open in Designer, but not in iBase User, with error message "Found in failed to write to Audit log"

Troubleshooting


Problem

An iBase database can open in iBase Designer, but not in iBase User, with error message "Found in failed to write to Audit log"
the full error message is :
iBase Error (System)
Tyypin i2.iBase.Error.iBaseException poikkeus.
Found in Failed to write to audit log
Stack trace:
   at i2.iBase.DBEngine.SQLServer.idDBEngine.i2.iBase.IntLib.IidDBEngine.WriteDatabaseLog(idDatabaseAuditType ActionType, String Detail, String[] Extras)
   at i2.iBase.CoreSystem.idDBConnection.Connect()
   at i2.iBase.CoreSystem.idDBSystem.OpenDB(Boolean InternalOnly, Boolean NoPrompt, String& DatabaseFile, String SecurityFile, String Username, String Password, Boolean Exclusive, Boolean ConnectLater, Boolean IgnoreDatabaseUsage, Boolean iBaseLogonOnly, Boolean blnRememberUserSelection)
   at i2.iBase.CoreSystem.idDBSystem.OpenDatabaseEx(Boolean NoPrompt, String DatabaseFile, String SecurityFile, String Username, String Password, Boolean Exclusive, Boolean ConnectLater, Boolean iBaseLogonOnly, Boolean RememberUserSelection)
   at i2.iBase.CoreSystem.idDBSystem.OpenDatabase(Boolean NoPrompt, String DatabaseFile, String SecurityFile, String Username, String Password, Boolean Exclusive, Boolean ConnectLater)
   at i2.iBase.Apps.User.FMain2.MobjAppCommands_DoCommand(Object source, DoCommandEventArgs e

Cause

This problem can happen on SQL Server iBase, when the LOG database is corrupted.

Resolving The Problem

 The general solution is to Backup, then delete the XXXX_LOG database.

Once the iBase DB is opened back in iBase Designer, this LOG DB will be recreated.

Below are the detailed, step-by-step instructions :

-       Close all iBase and ANB softwares

-       Open SQL Server Mgt Studio

-       Search for the name of the iBase DB. There should be 2 databases for this iBase. One has the suffix _LOG.

-       Right-Click on the LOG DB, then Properties. Go to Files.

-       Write down the location of the 2 files (mdf and ldf)

-       Close this window, and Right-click again on the _LOG database.

-       Detach the LOG DB. It should not appear anymore on the list of DB in SSMS.

-       Open a Windows browser window, then go to the folder where the mdf and ldf files are.

-       Move the XXXX_LOG.mdf and XXXX_LOG.ldf files to a different folder

-       Open the iBase DB in iBase Designer.

iBase Designer will notice that the XXXX_LOG database is missing, and it will recreate it.

This should take a couple of minutes.

Once the iBase DB opens in iBase Designer, you can close the Designer and open the iBase DB in iBase User. 

The problem should be fixed.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXW43","label":"i2 iBase"},"ARM Category":[{"code":"a8m50000000Ci9pAAC","label":"i2 iBase and i2 Analyst's WorkStation->Database"}],"ARM Case Number":"TS004738284","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
26 January 2021

UID

ibm16408624