Troubleshooting
Problem
In IBM i2 Analyst's Notebook, all the icons that are displayed in the "Insert from Palette" are represented by a white circle with black line, instead of their regular, normal icons.

None of the icons are displayed correctly.
Cause
The most probable cause is the presence of a corrupted PNG or JPG file in the Custom Icons folder.
Resolving The Problem
- Go in the Custom Icons folder (should be in My Documents/i2/i2 Shared/Custom Images/Screen/Icons )
- Check that each PNG and JPG file is correct (try to open each file, and check that it's an image).
- Also check the dimensions of the pictures. It's recommended to keep them under 256x256 pixels.
- Remove any JPG or PNG file that is not a valid picture
- Restart ANB and check that the problem is fixed.
If the custom icons are stored on a network drive (i.e, OneDrive) and you have the same issue. Please check that your network connection is active and you have the correct permissions to the folder/files.
Document Location
Worldwide
[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXW43","label":"i2 iBase"},"ARM Category":[{"code":"a8m500000008ZHtAAM","label":"i2 iBase and i2 Analyst's WorkStation"}],"ARM Case Number":"TS004574415","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.0.x"},{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"ARM Category":[{"code":"a8m500000008ZHeAAM","label":"i2 Analyst's Notebook"},{"code":"a8m500000008ZHeAAM","label":"i2 Analyst's Notebook"},{"code":"a8m500000008ZHeAAM","label":"i2 Analyst's Notebook"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.0.0;9.2.0;9.2.4"}]
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Document Information
Modified date:
28 September 2021
UID
ibm16407824