IBM Support

Disabling PM Agent

Troubleshooting


Problem

This document details how to disable the PM Agent product from running.

Cause

Effective 30 June 2020, IBM withdrew Performance Management for Power Systems (PM Agent / PM400) from marketing.
Support for this product withdrew effective 30 September 2020.

Withdrawn product

Withdrawal from marketing date

Withdrawal of support date

Performance Management for Power® Systems (PM) (6948-M17)

June 30, 2020

September 30, 2020

Diagnosing The Problem

Before disable PM Agent, assure that the following PTFs are on the system to prevent functional issues with Collection Services such as error messages and expired data not being cleaned up properly.

 
OS 7.3
Fix (Link to PTF Cover Letter) Cumulative Package Description
SI76181 C1245730 Collection Services collection expiration

Collection Services automatic restart
Historical Data retention periods
Expired Historical data fix
OS 7.4
Fix (Link to PTF Cover Letter) Cumulative Package Description
SI75847 C1238740 Collection Services automatic restart
SI76530 C1238740 Historical Data retention periods
SI76202 C1238740 Expired Historical data fix
If questions on disabling PM Agent, contact Small Products team.
If questions on the PTFs and Collection Services data, contact Performance team.
IBM Support: www.ibm.com/mysupport 

Resolving The Problem

This document details how to disable the PM Agent product from running. This will prevent the Q1PSCH job to be active and set PM Agent scheduler Inactive, as well as prevent data to be sending:

1. From Command Line, type CFGPMAGT and press ENTER

2. Press ENTER on ‘PM Agent Signoff Approval’ page

3. Enter option ‘0 = do not send performance data’ for ‘Select connectivity option for sending performance data to IBM’

4. Enter option ‘0 = No’ for ‘Receive performance data’ Press ENTER twice to return to the Command Line.

5. From Command Line, type GO PMAGT and press ENTER

6. Select option ‘2. Work with Automatically Scheduled Jobs’

7. Enter option ‘2=Change’ before each Scheduled Job that is listed (Q1PTEST, Q1PPMCHK, Q1PPMSUB, Q1PDR, Q1PPG)

8. On the ‘Change Automatically Scheduled Jobs’ screen, change ‘Status’ to ‘I=Inactive’ and press ENTER. Press F12 to return to the Command Entry

9. From Command Line, type the following command to remove Q1PSCH job:
CALL PGM(QSYS/Q1PENDPM) PARM('*IMMED    ' X'999999' X'00000000')
There must be four spaces after *IMMED and one space before each X.

Note:
PM Agent would periodically check if Collection Services is active. If Collection Services was not active, a message would be posted to QSYSOPR and a PMAgent scheduled job would re-start the collector after a certain amount of time. However, after PM Agent is disabled, if the Collection Services collector job (QYPSPFRCOL) ends for some reason (such as during a maintenance cycle or save operation), the job is not automatically restarted.  
Use the CHKPFRCOL command to determine if collection services is active or not. To restart the performance data collector job, it will need to use the STRPFRCOL command.

[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CHoAAM","label":"Performance"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0;7.2.0;7.3.0;7.4.0;7.5.0"}]

Document Information

Modified date:
27 December 2024

UID

nas8N1016856