IBM Support

Security Bulletin: IBM MQ could allow an authenticated user, under nondefault configuration, to cause a data corruption attack due to an error when using segmented messages. (CVE-2020-4592)

Security Bulletin


Summary

An issue was found within the MQ queue manager message processing logic that could allow an attacker to cause corrupt data when using segmented messages with a queue manager that is configured to use Linear Logging.

Vulnerability Details

CVEID:   CVE-2020-4592
DESCRIPTION:   IBM MQ could allow an authenticated user, under nondefault configuration to cause a data corruption attack due to an error when using segmented messages.
CVSS Base score: 5.3
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/184755 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N)

Affected Products and Versions

Affected Product(s) Version(s)
IBM MQ 9.1 LTS
IBM MQ 9.0 LTS
IBM MQ 8.0
IBM MQ 9.1 CD
IBM WebSphere MQ 7.5

Remediation/Fixes

IBM WebSphere MQ 7.5

Contact IBM Support and request a fix for APAR IT31663

IBM MQ 8.0

Apply interim fix for APAR IT31663

IBM MQ 9.0 LTS

Apply Fixpack 9.0.0.11

IBM MQ 9.1 LTS

Apply Fixpack 9.1.0.6

IBM MQ 9.1 CD

Upgrade to IBM MQ 9.2

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Change History

18 Dec 2020: Initial Publication
23 Dec 2020: Added details about linear logging

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSYHRD","label":"IBM MQ"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF051","label":"Linux on IBM Z Systems"},{"code":"PF027","label":"Solaris"},{"code":"PF012","label":"IBM i"},{"code":"PF033","label":"Windows"}],"Version":"7.5.0, 8.0.0, 9.0.0, 9.1.0","Edition":"All","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
23 December 2020

UID

ibm16387806