Troubleshooting
Problem
Unable to start Cognos.
Symptom
Open [Root_Cognos_installation_path]/logs/cbs_start_WebSphereLiberty.log file, error message created:
Day Mont date time ERROR t[xxx] CBSSocketCommand failed to connect, CAM error: <errorDetail><errorCode>-12</errorCode><errorMessage>CAM-CRP-0026 The underlying socket: 'server_name:port_number' returned an error.</errorMessage><errorStack><errorCode>10061</errorCode><errorMessage>Could not connect the socket, errno: xxxxx(10061)</errorMessage></errorStack></errorDetail>
Cause
Customer environment is using IPv6 protocol.
Resolving The Problem
Update environment to use IpV4 or update Cognos Configuration to use IPv6 protocol.
IBM® Cognos® products support two IP address versions: IPv4 and IPv6. IPv4 uses 32-bit IP addresses and IPv6 uses 128-bit IP addresses.
For example:
IPv4: 192.168.0.1:80
IPv6: [2001:0db8:0000:0000:0000:148:57ab]:80
For example:
IPv4: 192.168.0.1:80
IPv6: [2001:0db8:0000:0000:0000:148:57ab]:80
Related Information
Document Location
Worldwide
[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3yAAC","label":"Installation and Configuration"}],"ARM Case Number":"TS004604181","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
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Document Information
Modified date:
07 December 2020
UID
ibm16379144