IBM Support

Tenant id is missing error logging in with Content Analyzer

Troubleshooting


Problem

On a newly deployed IBM Business Automation Content Analyzer (ACA) system, login fails.  The user is given the message:
You are not authenticated properly.
The backend log shows:
2020-10-16 23:45:53 | spbackend-749d595cc5-l9zdb | ont1 | ont1 | INFO | buildTenantParamsForAPI: getting tenantInfo before building params.
2020-10-16 23:45:53 | spbackend-749d595cc5-l9zdb | ont1 | ont1 | ERROR | buildTenantParams: tenant id is missing or tenant info provided is invalid
2020-10-16 23:45:53 | spbackend-749d595cc5-l9zdb | ont1 | ont1 | ERROR | login routes: failed to build tenant params for API.

Cause

As part of logging in, ACA connects with the base database to get the information it needs to connect to and extract information from the tenant database.  If ACA can connect to the base database, but then cannot get the information from the tenant database, the error occurs.

Resolving The Problem

Check and verify the database, tid, and ontology values in all locations.  Important: Values are case-sensitive.
  • In the cr yaml, check that the base and tenant database information is correct in the dc_ca_datasource section.
  • If you are connecting by using the ACA frontend URL, check the tid and ont values in the URL.
  • Check the database values that were added by the AddTenant script when the database was created, by connecting to the base database and running:
    select * from tenantinfo

Document Location

Worldwide

[{"Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSUM7G","label":"IBM Business Automation Content Analyzer on Cloud"},"ARM Category":[{"code":"a8m0z0000001jAdAAI","label":"ACA Install\\Upgrade\\Setup"}],"ARM Case Number":"TS004228911","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
02 December 2020

UID

ibm16373868