IBM Support

Issues with Rational Developer for i V9.6.0.x and macOS Big Sur (version 11)

Troubleshooting


Problem

With macOS Big Sur (version 11), there are various issues involved with using, installing, and updating Rational Developer for i 9.6.

Resolving The Problem

macOS Big Sur is not one of the supported platforms for Rational Developer for i 9.6.
The issues are being investigated and workarounds will be documented if found.  In the meantime, it is not recommended to upgrade to Big Sur as it is likely that the product will not work.
Regarding IBM Installation Manager, ensure you are using the latest version (v1.9.1.5 minimum) and use User mode install (Userinst.app) instead of Admin mode install (Install.app) to avoid issues.   Also, running it from the command line instead of the GUI might avoid some additional issues.  See the IBM Installation Manager Documentation site for more information.  Note: after downloading the Installation Manager .zip file, from Terminal run 'xattr -c <Path to the Installation Manager .zip file>' before you extract it to avoid some MacOS Gatekeeper issues.
If you have already upgraded, you can either:
  • Downgrade to a previous macOS release
  • Install the product in a virtual machine running a supported release

Document Location

Worldwide

[{"Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSAE4W","label":"Rational Developer for i"},"ARM Category":[{"code":"a8m0z0000000930AAA","label":"Developer for Power->Install"}],"ARM Case Number":"","Platform":[{"code":"PF017","label":"Mac OS"}],"Version":"9.6.0"}]

Document Information

Modified date:
21 June 2021

UID

ibm16373030