IBM Support

LPAR boot on Power9 stops with CA000040

Troubleshooting


Problem

An LPAR on a Power9 system can hang during boot at progress code CA000040 if the system has been powered on for at least 814 days.

Symptom

LPAR does not boot past progress code CA000040 when activated.  The system has been powered on at least 814 days.  And SRC B200F003 might be reported in the iqyylog.

Cause

This problem is caused by a new timer variable implemented at Power9 used for creating delay timers. All Power9 systems powered on for at least 814 days are exposed.

Environment

Any Power9 system with system firmware older than FW930.30 or older than FW940.30 that has been powered on for at least 814 days.

Diagnosing The Problem

To verify how long a system has been running, check the SRC history in ASMI:
  1. Access ASMI
  2. Log in as user celogin.
  3. Navigate to System Information -> Progress Indicator History.
  4. Search for the most recent STANDBY entry.  If the date of that entry is at least 814 days ago, this problem might occur.
If ASMI cannot be accessed or the last STANDBY entry cannot be found, a nondisruptive resource dump would also include this information.

Resolving The Problem

This problem is resolved in system firmware versions FW930.30, FW940.30, and FW950.00 and newer.
There are two workarounds that can be used until system firmware with the fix is installed.
  1. Stop the LPAR, edit the LPAR's profile to set its processor compatibility mode to Power8, and activate the LPAR from the altered profile.  This change needs to be made for each LPAR experiencing this problem. 
  2. Powering the system off and on again resets the timer and allow all LPARs to boot again without changing their processor compatibility mode.  The system firmware must be updated before another 814 days have passed or the same problem might happen again.

Document Location

Worldwide

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Document Information

Modified date:
03 November 2023

UID

ibm16370613