IBM Support

Security Bulletin: Vulnerability in Docker affects Cloud Pak Sytem (CVE-2020-13401)

Security Bulletin


Summary

Vulnerability identified within Docker shipped as pType component with Cloud Pak System Software. IBM Cloud Pak System Software addressed this vulnerability.

Vulnerability Details

CVEID:   CVE-2020-13401
DESCRIPTION:   Docker Docker CE is vulnerable to a man-in-the-middle attack, caused by improper validation of router advertisements. By sending rogue router advertisements, an attacker could exploit this vulnerability using man-in-the-middle techniques to gain access to the communication channel between endpoints to obtain sensitive information or further compromise the system.
CVSS Base score: 6
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/182750 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L)

Affected Products and Versions

Affected Product(s)Version(s)
IBM Cloud Pak System  2.2.6 
IBM Cloud Pak System

 

2.3.0.1,  2.3.1.1, 2.3.2.0


Remediation/Fixes

For all minor release version that are end of support and unsupported releases the recommendation is to upgrade to latest fixed release. 

For Cloud Pak System 2.2.6  OS Images on Red Hat Linux Enterprise refer to : https://access.redhat.com/security/cve/cve-2020-13401. Contact IBM Cloud Pak  System support for assistance.

OR 

upgrade to then to IBM Cloud Pak System 2.3.3.0.

For IBM Cloud Pak System v2.3.0.1, v2.3.1.1, v.2.3.2.0 ,  

upgrade to IBM Cloud Pak System v2.3.3.0

Information on upgrading can be found here:  https://www.ibm.com/support/pages/node/887959

 

Workarounds and Mitigations

Prevent untrusted, non-privileged containers from running with CAP_NET_RAW.

 

Get Notified about Future Security Bulletins

References

Off

Change History

2 Aug 2020: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document Location

Worldwide

[{"Business Unit":{"code":"BU025","label":"IBM Cloud and Cognitive Software"},"Product":{"code":"SSFQWQ","label":"IBM Cloud Pak System"},"Component":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"2.3","Edition":""}]

Document Information

Modified date:
12 October 2020

UID

ibm16347174