IBM Support

Cloud Pak for Security V1.4 install error "jobs.batch is forbidden"

Troubleshooting


Problem

Cloud Pak for Security offers multiple ways to install V1.4. One of the key methods is CASE install. When installing Cloud Pak for security, user may into error : "Error from server (Forbidden): jobs.batch is forbidden: User "admin" cannot list resource "jobs" in API group "batch" in the namespace "kube-system"".

Cause

This error is caused by admin being logged out of OC either by timeout or not being logged in.

Resolving The Problem

In order to resolve this error:
Please login to OC and try install again.
Examples:

oc login --token=xxxxxxxxxxxx --server=https://a121-xxx-xxx.containers.cloud.ibm.com:12345

or

Oc login -a url -u kubeadmin -p password..

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m0z0000001h8uAAA","label":"Install"}],"ARM Case Number":"TS004276442","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
01 October 2020

UID

ibm16340239